summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Beeh2018-06-20 13:34:33 +0200
committerTobias Beeh2018-06-20 13:36:52 +0200
commit117946405a05b4cb1d7cbb3ec0c5725bef5edb15 (patch)
tree84dd1d89640c265aadf80caca9fee315a0dc2598
downloadaur-117946405a05b4cb1d7cbb3ec0c5725bef5edb15.tar.gz
created package for eclipse modeling tools
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--eclipse-modeling.desktop10
-rw-r--r--eclipse-modeling.sh3
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6c3db5ababe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = eclipse-modeling-tools
+ pkgdesc = The eclipse IDE with the eclipse modeling tools as a standalone package (not directly interfering with a standard eclipse)
+ pkgver = 4.7.3a
+ pkgrel = 1
+ url = https://www.eclipse.org/modeling
+ arch = x86_64
+ license = EPL
+ depends = java-environment>=8
+ depends = unzip
+ depends = webkit2gtk
+ options = !strip
+ source = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/oxygen/3a/eclipse-modeling-oxygen-3a-linux-gtk-x86_64.tar.gz
+ source = eclipse-modeling.sh
+ source = eclipse-modeling.desktop
+ sha512sums = c859e65bd2d824e70cec5f3b5f8617d6c59cf74ba703c3193290825577ce8d252f5530c4576df29cf1781ddc084eced762898de0ff23c0288765266dcda3696e
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = eclipse-modeling-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cecdf5655784
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tobias Beeh <tobias beeh at tum de>
+
+pkgname=eclipse-modeling-tools
+pkgver=4.7.3a
+pkgrel=1
+pkgdesc="The eclipse IDE with the eclipse modeling tools as a standalone package (not directly interfering with a standard eclipse)"
+url="https://www.eclipse.org/modeling"
+arch=("x86_64")
+license=("EPL")
+depends=("java-environment>=8" "unzip" "webkit2gtk")
+optdepends=()
+options=(!strip)
+
+source=(
+ "http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/oxygen/3a/eclipse-modeling-oxygen-3a-linux-gtk-x86_64.tar.gz"
+ "eclipse-modeling.sh"
+ "eclipse-modeling.desktop"
+)
+
+sha512sums=(
+ "c859e65bd2d824e70cec5f3b5f8617d6c59cf74ba703c3193290825577ce8d252f5530c4576df29cf1781ddc084eced762898de0ff23c0288765266dcda3696e"
+# "71393b01c2774654e1b3348ceedd6b110c7f1b26da93da40dac653ce2103a34997ec0e9e7fd4e977d869c149d19ef39f59738717cc6762e39b0bc0e7d53df4ac"
+# "0c556325621888765d8aa41187e0d2f1dcc3ce81ca20fd8fe7bb678d61e322bc8de30519962dfeefc3d707836275010b0369c5a304405c20737b622487f1fc6c"
+ SKIP
+ SKIP
+)
+
+package() {
+ install -d ${pkgdir}/usr/bin ${pkgdir}/usr/lib ${pkgdir}/usr/share/applications
+
+ install -m755 "${srcdir}/eclipse-modeling.sh" "${pkgdir}/usr/bin/eclipse-modeling"
+ install -Dm644 "${srcdir}/eclipse-modeling.desktop" "${pkgdir}/usr/share/applications/"
+
+ for _i in 16 32 48 256; do
+ install -Dm644 "${srcdir}"/eclipse/plugins/org.eclipse.platform_*/eclipse${_i}.png "$pkgdir/usr/share/icons/hicolor/${_i}x${_i}/apps/eclipse-modeling.png"
+ done
+
+ mv "${srcdir}/eclipse" "${pkgdir}/usr/lib/eclipse-modeling"
+}
diff --git a/eclipse-modeling.desktop b/eclipse-modeling.desktop
new file mode 100644
index 000000000000..a1809fc0e6ac
--- /dev/null
+++ b/eclipse-modeling.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=4.7
+Name=Eclipse Modeling
+Comment=The Eclipse Modeling Tools
+Exec=eclipse-modeling
+Icon=eclipse-modeling
+Terminal=false
+Categories=GTK;Development;IDE;Modeling
+StartupNotify=true
diff --git a/eclipse-modeling.sh b/eclipse-modeling.sh
new file mode 100644
index 000000000000..80b9786512a3
--- /dev/null
+++ b/eclipse-modeling.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+export ECLIPSE_HOME=/usr/lib/eclipse-modeling
+exec ${ECLIPSE_HOME}/eclipse "$@"