summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commitf53218a11fe00923a8c585f6a3d5758b32b61beb (patch)
tree5e4ab09c3db97f6ccc34ac0aa2758bf6a28dd76d
downloadaur-f53218a11fe00923a8c585f6a3d5758b32b61beb.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75f754773ce3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-pde
+ pkgdesc = Plug-in Development Environment - Separated from Eclipse SDK package. Use with eclipse-platform
+ pkgver = 4.4
+ pkgrel = 1
+ url = http://www.eclipse.org/pde/
+ arch = any
+ license = EPL
+ makedepends = unzip
+ depends = eclipse-platform
+ options = !strip
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/eclipse/downloads/drops4/R-4.4-201406061215/org.eclipse.pde-4.4.zip
+ md5sums = 2361263bdd3ba61108288a188b6fa282
+
+pkgname = eclipse-pde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..513ab3e9712a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Shanto <shanto@hotmail.com>
+# Contributor: Jesus Jerez <jerezmoreno@gmail.com>
+
+pkgname=eclipse-pde
+pkgver=4.4
+pkgdate=201406061215
+pkgrel=1
+pkgdesc="Plug-in Development Environment - Separated from Eclipse SDK package. Use with eclipse-platform"
+url="http://www.eclipse.org/pde/"
+arch=('any')
+license=('EPL')
+depends=('eclipse-platform')
+makedepends=('unzip')
+options=(!strip)
+source=("http://www.eclipse.org/downloads/download.php?r=1&file=/eclipse/downloads/drops4/R-${pkgver}-${pkgdate}/org.eclipse.pde-${pkgver}.zip")
+md5sums=('2361263bdd3ba61108288a188b6fa282')
+
+package() {
+
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+
+}