summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Mailänder2023-10-31 17:40:31 +0100
committerMatthias Mailänder2023-10-31 17:40:31 +0100
commit7ae9144b1c22ab9b554a7fc804e5c04152484d63 (patch)
tree630fb3367367c1db2be54becf4f07a0578a6172c
downloadaur-7ae9144b1c22ab9b554a7fc804e5c04152484d63.tar.gz
Initial packaging
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
-rw-r--r--eclipse-rcptt.desktop9
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63db2f850d1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-rcptt
+ pkgdesc = Eclipse RCP Testing Tool IDE
+ pkgver = 2.5.4
+ pkgrel = 1
+ epoch = 1
+ url = https://eclipse.org/rcptt
+ arch = x86_64
+ license = EPL
+ depends = java-environment>=17
+ source = rcptt.ide-2.5.4-linux.gtk.x86_64.zip::https://www.eclipse.org/downloads/download.php?file=/rcptt/release/2.5.4/ide/rcptt.ide-2.5.4-linux.gtk.x86_64.zip&r=1
+ source = eclipse-rcptt.desktop
+ sha512sums = 3c4120932afdef245b265ce0775fe11f075e1427d92c69e4fa71390199e1b59d5534a18cfc0fd1c38de23fa89c1627a6ece562d6c1ddb5dfcf7ad476488c6c28
+ sha512sums = 002a074ce1a41bc84bf688c21e3e8e94ba4662b167f459e5cc46397434565fab30520cc78e062407ac7eaba73d84604ff2d16aa27c3aa2d39cc9aea27d969d8c
+
+pkgname = eclipse-rcptt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ccf73fbfd01
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.tar.zst
+/*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cba40c50bd74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Matthias Mailänder <matthias [at] mailaender [dot] name>
+
+pkgname=eclipse-rcptt
+epoch=1
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="Eclipse RCP Testing Tool IDE"
+arch=('x86_64')
+url="https://eclipse.org/rcptt"
+license=('EPL')
+depends=('java-environment>=17')
+source=("rcptt.ide-$pkgver-linux.gtk.x86_64.zip::https://www.eclipse.org/downloads/download.php?file=/rcptt/release/$pkgver/ide/rcptt.ide-$pkgver-linux.gtk.x86_64.zip&r=1"
+ "eclipse-rcptt.desktop")
+sha512sums=('3c4120932afdef245b265ce0775fe11f075e1427d92c69e4fa71390199e1b59d5534a18cfc0fd1c38de23fa89c1627a6ece562d6c1ddb5dfcf7ad476488c6c28'
+ '002a074ce1a41bc84bf688c21e3e8e94ba4662b167f459e5cc46397434565fab30520cc78e062407ac7eaba73d84604ff2d16aa27c3aa2d39cc9aea27d969d8c')
+
+package() {
+ install -d "${pkgdir}/usr/lib"
+ cp -r "rcptt" "${pkgdir}/usr/lib/eclipse-rcptt"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/eclipse-rcptt/rcptt" "${pkgdir}/usr/bin/eclipse-rcptt"
+
+ mkdir -p "${pkgdir}/usr/share/pixmaps/"
+ ln -s "/usr/lib/eclipse-rcptt/icon.xpm" "${pkgdir}/usr/share/pixmaps/eclipse-rcptt.xpm"
+
+ install -Dm0644 "eclipse-rcptt.desktop" "${pkgdir}/usr/share/applications/eclipse-rcptt.desktop"
+}
diff --git a/eclipse-rcptt.desktop b/eclipse-rcptt.desktop
new file mode 100644
index 000000000000..5ebfb0a057fd
--- /dev/null
+++ b/eclipse-rcptt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Eclipse RCPTT
+GenericName=UI Testing IDE
+Comment=Eclipse RCP Testing Tool
+Icon=eclipse-rcptt
+Exec=eclipse-rcptt
+Terminal=false
+Categories=Development;IDE;