summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2018-12-21 12:27:26 +0100
committerRaimar Bühmann2018-12-21 12:27:26 +0100
commit7be9610e31ffa03f4b4456b774037b4fb2ade323 (patch)
treefdf9b5f658d0c1f78a0da1a359f247a4dd5a4e87
parent72e3ea5bfc6ac9f770336fa75a7aeae849595a01 (diff)
downloadaur-7be9610e31ffa03f4b4456b774037b4fb2ade323.tar.gz
add feature.jar
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c8a53182421..34c5fdef1db8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eclipse-spotbugs
pkgdesc = SpotBugs plugin for Eclipse IDE to look for bugs in Java code by static code analysis
pkgver = 3.1.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/spotbugs/spotbugs/
arch = any
license = LGPL
@@ -9,7 +9,9 @@ pkgbase = eclipse-spotbugs
noextract = feature.jar
noextract = plugin.jar
options = !strip
+ source = feature.jar::https://spotbugs.github.io/eclipse-stable-latest/features/com.github.spotbugs.plugin.eclipse_3.1.11.201812210434-554d102.jar
source = plugin.jar::https://spotbugs.github.io/eclipse-stable-latest/plugins/com.github.spotbugs.plugin.eclipse_3.1.11.201812210434-554d102.jar
+ sha256sums = ed197bcba2685dd4dabf9bc421cee7a26de8ad4bbe2069fe09b0c562aa1e3bc6
sha256sums = 653cd15370db01244bc00c1521fedc8019a09befd1be8d5c4a1b556d7fa54a32
pkgname = eclipse-spotbugs
diff --git a/PKGBUILD b/PKGBUILD
index 3c8c0d986e6b..6f70b31425ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=eclipse-spotbugs
pkgver=3.1.11
_buildtime=201812210434-554d102
-pkgrel=1
+pkgrel=2
pkgdesc='SpotBugs plugin for Eclipse IDE to look for bugs in Java code by static code analysis'
arch=('any')
url='https://github.com/spotbugs/spotbugs/'
@@ -11,19 +11,20 @@ license=('LGPL')
depends=('eclipse>=4.5.0')
options=('!strip')
source=(
-# "feature.jar::https://spotbugs.github.io/eclipse-stable-latest/features/com.github.spotbugs.plugin.eclipse.feature_${pkgver}.${_buildtime}.jar"
+ "feature.jar::https://spotbugs.github.io/eclipse-stable-latest/features/com.github.spotbugs.plugin.eclipse_${pkgver}.${_buildtime}.jar"
"plugin.jar::https://spotbugs.github.io/eclipse-stable-latest/plugins/com.github.spotbugs.plugin.eclipse_${pkgver}.${_buildtime}.jar"
)
noextract=(feature.jar plugin.jar)
-sha256sums=('653cd15370db01244bc00c1521fedc8019a09befd1be8d5c4a1b556d7fa54a32')
+sha256sums=('ed197bcba2685dd4dabf9bc421cee7a26de8ad4bbe2069fe09b0c562aa1e3bc6'
+ '653cd15370db01244bc00c1521fedc8019a09befd1be8d5c4a1b556d7fa54a32')
package() {
_dest=$pkgdir/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
-# _subfolder=$_dest/features/net.sourceforge.pmd.eclipse_${pkgver}.${_buildtime}
-# install -dm755 $_subfolder
-# cd $_subfolder
+ _subfolder=$_dest/features/com.github.spotbugs.plugin.eclipse_${pkgver}.${_buildtime}
+ install -dm755 $_subfolder
+ cd $_subfolder
# extract feature
-# jar xf $srcdir/feature.jar || return 1
+ jar xf $srcdir/feature.jar || return 1
# copy plugin
install -Dm644 $srcdir/plugin.jar $_dest/plugins/com.github.spotbugs.plugin.eclipse_${pkgver}.${_buildtime}.jar
}