summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2019-11-09 13:26:28 +0100
committerRaimar Bühmann2019-11-09 13:26:28 +0100
commit036aa18fb5e7fecfa2477a3b2dd13092e3422098 (patch)
tree664b10d4366bc45eccd574ba88e161527dcc862a
downloadaur-036aa18fb5e7fecfa2477a3b2dd13092e3422098.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd955886080d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-sql-explorer
+ pkgdesc = SQL Explorer plugin for Eclipse IDE
+ pkgver = 3.6.2
+ pkgrel = 1
+ url = https://sourceforge.net/projects/eclipsesql/
+ arch = any
+ license = LGPL2.0
+ depends = eclipse>=4.5.0
+ options = !strip
+ source = download.zip::https://downloads.sourceforge.net/project/eclipsesql/SQL%20Explorer%20Plugin/3.6.2/sqlexplorer_plugin-3.6.2.zip
+ sha256sums = 05c4a361fab1ddf4105bd29096acba19aafd818de19767e20c61df08e243849b
+
+pkgname = eclipse-sql-explorer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..77f96710c047
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+eclipse-*-any.pkg.tar.xz
+download.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108a5a598337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
+
+pkgname=eclipse-sql-explorer
+pkgver=3.6.2
+pkgrel=1
+pkgdesc="SQL Explorer plugin for Eclipse IDE"
+arch=('any')
+url="https://sourceforge.net/projects/eclipsesql/"
+license=('LGPL2.0')
+depends=('eclipse>=4.5.0')
+options=('!strip')
+source=("download.zip::https://downloads.sourceforge.net/project/eclipsesql/SQL%20Explorer%20Plugin/$pkgver/sqlexplorer_plugin-$pkgver.zip")
+sha256sums=('05c4a361fab1ddf4105bd29096acba19aafd818de19767e20c61df08e243849b')
+
+package() {
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ cd ${srcdir}
+
+ # remove features and plug-ins containing sources
+ rm features/*.source_*
+ rm plugins/*.source_*
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}
+