summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Robin2015-06-11 19:54:41 +0200
committerBenjamin Robin2015-06-11 19:54:41 +0200
commit97786f1559c261615a56101042d5978f5cf6d636 (patch)
tree0138fa4bb4436497d2327d6351d085db3bd80c93
downloadaur-97786f1559c261615a56101042d5978f5cf6d636.tar.gz
Copied from AUR 3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7003f0009321
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = eclipse-subversive-svn-connector
+ pkgdesc = Subversive SVN Connectors
+ pkgver = 4.1.3.I20150214_1700
+ pkgrel = 1
+ url = http://www.polarion.com/products/svn/subversive.php
+ arch = any
+ license = EPL
+ depends = eclipse-subversive
+ noextract = eclipse-subversive-svn-connector-4.1.3.I20150214_1700-feature.jar
+ noextract = eclipse-subversive-svn-connector-4.1.3.I20150214_1700-plugin.jar
+ source = eclipse-subversive-svn-connector-4.1.3.I20150214_1700-feature.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/features/org.polarion.eclipse.team.svn.connector_4.1.3.I20150214-1700.jar
+ source = eclipse-subversive-svn-connector-4.1.3.I20150214_1700-plugin.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/plugins/org.polarion.eclipse.team.svn.connector_4.1.3.I20150214-1700.jar
+ md5sums = 0d126ced1e7455dde98458202a5b1a89
+ md5sums = cf4746777c5d5b9caa8c1bbfcdaa233d
+
+pkgname = eclipse-subversive-svn-connector
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73a72a5f1759
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Benjamin Robin <benjarobin>
+
+pkgname=eclipse-subversive-svn-connector
+pkgver=4.1.3.I20150214_1700
+pkgrel=1
+_pluginver=4.1.3.I20150214_1700
+pkgdesc="Subversive SVN Connectors"
+arch=('any')
+url="http://www.polarion.com/products/svn/subversive.php"
+license=('EPL')
+depends=('eclipse-subversive')
+
+source=("$pkgname-$pkgver-feature.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/features/org.polarion.eclipse.team.svn.connector_${pkgver//_/-}.jar" \
+ "$pkgname-$pkgver-plugin.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/plugins/org.polarion.eclipse.team.svn.connector_${_pluginver//_/-}.jar")
+
+noextract=($pkgname-$pkgver-{feature,plugin}.jar)
+md5sums=('0d126ced1e7455dde98458202a5b1a89'
+ 'cf4746777c5d5b9caa8c1bbfcdaa233d')
+package()
+{
+ _dest="$pkgdir/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse"
+
+ # Feature(s)
+ install -d -m755 $_dest/features/org.polarion.eclipse.team.svn.connector_${pkgver//_/-}
+ cd $_dest/features/org.polarion.eclipse.team.svn.connector_${pkgver//_/-}
+ jar xf $srcdir/$pkgname-$pkgver-feature.jar
+
+ # Plugin(s)
+ install -D -m644 $srcdir/$pkgname-$pkgver-plugin.jar $_dest/plugins/org.polarion.eclipse.team.svn.connector_${_pluginver//_/-}.jar
+}
+