diff options
author | Vadim Yanitskiy | 2024-09-17 03:47:21 +0700 |
---|---|---|
committer | Vadim Yanitskiy | 2024-09-17 22:17:56 +0700 |
commit | fa875b618805c2ececd709267acdcb404c5018a6 (patch) | |
tree | b4f2748ce6dfd90dc1236664d8ec81a1c3c2e38d | |
parent | 3764e0b8655cf179fdf98718b8121ea05d492dec (diff) | |
download | aur-fa875b618805c2ececd709267acdcb404c5018a6.tar.gz |
prepare(): do not let it strip binaries
We need symbols in order to create a debug package. The project's
build system currently strips the symbols on its own while executing
the 'install' target, preventing makepkg to create a debug package.
Trick the build system to use 'touch -c', which does nothing, so that
makepkg can extract symbols properly and strip them (if needed).
-rw-r--r-- | PKGBUILD | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -39,6 +39,7 @@ options=(!lto !buildflags !makeflags) prepare() { cd "${srcdir}/${_pkgname}-${pkgver}" + echo "STRIP := touch -c" >> Makefile.personal echo "TTCN3_DIR := /opt/eclipse-titan" >> Makefile.personal echo "JDKDIR := /usr/lib/jvm/$(archlinux-java get)" >> Makefile.personal } |