summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2019-10-06 09:26:12 +0200
committerRaimar Bühmann2019-10-06 09:26:12 +0200
commit44eebb7ea202a8c7399f88e38940f024e7440b0e (patch)
tree913f2dc5ed58d7f0fbf120a55658def47a039856
downloadaur-44eebb7ea202a8c7399f88e38940f024e7440b0e.tar.gz
init with 3.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3243b1ab5ff7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-tpd
+ pkgdesc = Target Platform DSL plug-in for Eclipse IDE
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/mbarbero/fr.obeo.releng.targetplatform
+ arch = any
+ license = EPL1.0
+ depends = eclipse-tmf-xtext
+ depends = eclipse-m2t-xpand
+ options = !strip
+ source = https://download.eclipse.org/cbi/tpd/3.0.0-SNAPSHOT/org.eclipse.cbi.targetplatform-3.0.0.201902111444.zip
+ sha256sums = 3e754e44fd0c1b4d2b68e3d3bdd41c040fc14c9639946dc911d4ec8e17c6ab79
+
+pkgname = eclipse-tpd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa9adc91945d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+eclipse-*.pkg.tar.xz
+EMF-Updates-*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24304bfc9094
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
+
+pkgname=eclipse-tpd
+pkgver=3.0.0
+_buildtime=201902111444
+pkgrel=1
+pkgdesc="Target Platform DSL plug-in for Eclipse IDE"
+arch=('any')
+url="https://github.com/mbarbero/fr.obeo.releng.targetplatform"
+license=('EPL1.0')
+depends=(eclipse-tmf-xtext eclipse-m2t-xpand)
+options=('!strip')
+# https://download.eclipse.org/cbi/tpd/3.0.0-SNAPSHOT/
+source=(
+ https://download.eclipse.org/cbi/tpd/${pkgver}-SNAPSHOT/org.eclipse.cbi.targetplatform-${pkgver}.${_buildtime}.zip
+# "https://mbarbero.github.io/fr.obeo.releng.targetplatform/p2/${pkgver/\.1}/$pkgver.$_buildtime/plugins/fr.obeo.releng.targetplatform_$pkgver.$_buildtime.jar"
+# "https://mbarbero.github.io/fr.obeo.releng.targetplatform/p2/${pkgver/\.1}/$pkgver.$_buildtime/plugins/fr.obeo.releng.targetplatform.ui_$pkgver.$_buildtime.jar"
+)
+# do not extract all package sources
+#noextract=("${source[@]##*/}")
+sha256sums=('3e754e44fd0c1b4d2b68e3d3bdd41c040fc14c9639946dc911d4ec8e17c6ab79')
+package() {
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ install -d $_dest
+ # extract features (otherwise features are not recognized)
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+ # copy plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}