summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit2ea5ddba2ac442e6344ae1f2bdd7a7b42b0f0b60 (patch)
tree0e4a378d02d917217fb8da9a74ca30c5bf8612b5
downloadaur-2ea5ddba2ac442e6344ae1f2bdd7a7b42b0f0b60.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32a8e391daa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-viplugin
+ pkgdesc = ViPlugin for Eclipse
+ pkgver = 2.13.1
+ pkgrel = 1
+ url = http://www.viplugin.com/
+ arch = i686
+ arch = x86_64
+ license = Commercial
+ depends = eclipse
+ noextract = viPlugin_2.13.1.zip
+ source = http://www.viplugin.com//files/viPlugin_2.13.1.zip
+ md5sums = f4124af1317c76ab5056549c5d3a42c2
+
+pkgname = eclipse-viplugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..403a047c4539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Author: Michael Bartl <gnosticus@gmx.at>
+# Packager: Samir Faci <csgeek@archlinux.us>
+# Maintainer: Arthur Zamarin
+
+pkgname=eclipse-viplugin
+pkgver=2.13.1
+pkgrel=1
+pkgdesc="ViPlugin for Eclipse"
+arch=('i686' 'x86_64')
+url="http://www.viplugin.com/"
+license=('Commercial')
+depends=('eclipse')
+source=("${url}/files/viPlugin_${pkgver}.zip")
+noextract=("viPlugin_${pkgver}.zip")
+md5sums=('f4124af1317c76ab5056549c5d3a42c2')
+
+package() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/viPlugin/eclipse
+ mkdir -p ${_dest}
+ unzip $srcdir/viPlugin_$pkgver.zip -d ${_dest}
+}
+# vim:set ts=4 sw=4 et: