summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUmamiAppearance2022-12-13 12:20:59 +0100
committerUmamiAppearance2022-12-13 12:20:59 +0100
commit3deb8a505adfa3fce647595561b68fc5892e7f88 (patch)
treea5052e0bbb963e230bf13baebb92618de10da5cc
downloadaur-3deb8a505adfa3fce647595561b68fc5892e7f88.tar.gz
Initial Release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32aa7f28e9b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ecoji
+ pkgdesc = Encode or decode data as Unicode emojis.
+ pkgver = 2.0.1+5+g805d064
+ pkgrel = 1
+ url = https://github.com/keith-turner/ecoji
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/keith-turner/ecoji
+ sha256sums = SKIP
+
+pkgname = ecoji
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f98b51d4d5ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=ecoji
+pkgver=2.0.1+5+g805d064
+pkgrel=1
+pkgdesc="Encode or decode data as Unicode emojis."
+arch=("x86_64")
+url="https://github.com/keith-turner/ecoji"
+license=("APACHE")
+makedepends=(git go)
+source=("git+$url")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $pkgname
+ mkdir -p build/
+ git describe --tags | sed "s/^v//;s/-/+/g"
+}
+
+build() {
+ cd "$pkgname"/cmd
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o ../build ./ecoji.go
+}
+
+
+package() {
+ cd "$pkgname"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}