summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUmamiAppearance2022-12-13 13:06:26 +0100
committerUmamiAppearance2022-12-13 13:06:26 +0100
commit7ae82c758c497bb6c528164291fc0b483ea76f63 (patch)
tree6510936d7a524de0101088cdaef24ec092fb4934
parent3deb8a505adfa3fce647595561b68fc5892e7f88 (diff)
downloadaur-7ae82c758c497bb6c528164291fc0b483ea76f63.tar.gz
Inpoved build functions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32aa7f28e9b7..2d59ecb1f07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = ecoji
pkgdesc = Encode or decode data as Unicode emojis.
- pkgver = 2.0.1+5+g805d064
- pkgrel = 1
+ pkgver = 2.0.1
+ pkgrel = 2
url = https://github.com/keith-turner/ecoji
arch = x86_64
- license = APACHE
+ license = Apache
makedepends = git
makedepends = go
source = git+https://github.com/keith-turner/ecoji
diff --git a/PKGBUILD b/PKGBUILD
index f98b51d4d5ef..85d9e9593481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
pkgname=ecoji
-pkgver=2.0.1+5+g805d064
-pkgrel=1
+pkgver=2.0.1
+pkgrel=2
pkgdesc="Encode or decode data as Unicode emojis."
arch=("x86_64")
url="https://github.com/keith-turner/ecoji"
-license=("APACHE")
+license=("Apache")
makedepends=(git go)
source=("git+$url")
sha256sums=("SKIP")
pkgver() {
cd $pkgname
- mkdir -p build/
git describe --tags | sed "s/^v//;s/-/+/g"
}
+prepare() {
+ cd $pkgname
+ mkdir -p build/
+}
+
build() {
cd "$pkgname"/cmd
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -25,7 +29,6 @@ build() {
go build -o ../build ./ecoji.go
}
-
package() {
cd "$pkgname"
install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname