summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-03-16 19:12:19 -0500
committerDoug Newgard2013-03-16 19:12:19 -0500
commit2fe66f12dafc435d6eab6c9ff5f1bddf1eaaf82c (patch)
tree459c68a100792afa2a77c470f9dbc9fdc8d489e8
downloadaur-2fe66f12dafc435d6eab6c9ff5f1bddf1eaaf82c.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7043f1e3621
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = econnman
+ pkgdesc = Enlightenment ConnMan user interface
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.enlightenment.org
+ arch = any
+ license = LGPL3
+ depends = python2-elementary
+ depends = python2-e_dbus
+ depends = python2-edje
+ depends = python2-ecore
+ depends = connman
+ conflicts = econnman-svn
+ source = http://packages.profusion.mobi/econnman/econnman-1.tar.gz
+ md5sums = cec2bd0aaf9d8975dd69ac6b5a4e638e
+
+pkgname = econnman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cfd5f1c65302
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*~
+src/
+pkg/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d68389c451a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Doug Newgard <scimmia22 at outlook dot com>
+
+pkgname=econnman
+pkgver=1
+pkgrel=1
+pkgdesc="Enlightenment ConnMan user interface"
+arch=('any')
+url="http://www.enlightenment.org"
+license=('LGPL3')
+depends=('python2-elementary' 'python2-e_dbus' 'python2-edje' 'python2-ecore' 'connman')
+conflicts=('econnman-svn')
+source=("http://packages.profusion.mobi/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('cec2bd0aaf9d8975dd69ac6b5a4e638e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i 's:/usr/bin/python:/usr/bin/python2:g' econnman-bin.in
+
+ PYTHON=/usr/bin/python2 \
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}