summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorny-a2021-10-22 11:59:50 +0900
committerny-a2021-10-22 11:59:50 +0900
commit04574fda85cd8274d679e5bb5ecec2de592136be (patch)
treecb51b22939540a48bd3c947ce6e7da3a3790ce70
downloadaur-04574fda85cd8274d679e5bb5ecec2de592136be.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c22182a2f87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ecspresso
+ pkgdesc = Deployment tool for Amazon ECS
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/kayac/ecspresso
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/kayac/ecspresso/archive/refs/tags/v1.6.2.tar.gz
+ sha256sums = 4c24e13aa96495c48c934521b902701bfd680cb44c132c1e97552b55119f9bc4
+
+pkgname = ecspresso
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9fb789c3c7f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.zst
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6e9a7a55a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: ny-a <nyaarch64@gmail..com>
+
+pkgname=ecspresso
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Deployment tool for Amazon ECS"
+arch=('x86_64')
+url="https://github.com/kayac/ecspresso"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=("https://github.com/kayac/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('4c24e13aa96495c48c934521b902701bfd680cb44c132c1e97552b55119f9bc4')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build "./cmd/$pkgname"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: