summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2018-06-30 00:17:22 -0400
committerWilliam J. Bowman2018-06-30 00:29:21 -0400
commita79be0ea10037c1ea72508c42fa87283ab46bb30 (patch)
treeac04f3fe9209f2fb91aff4c438095b364601161b
downloadaur-a79be0ea10037c1ea72508c42fa87283ab46bb30.tar.gz
Updated to 0.8.2-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..507d59d5d942
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ect
+ pkgdesc = Efficient Compression Tool (or ECT) is a ++ file optimizer. It supports PNG, JPEG, GZIP and ZIP files.
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://github.com/fhanau/Efficient-Compression-Tool
+ arch = i686
+ arch = x86_64
+ license = Apache2
+ makedepends = nasm
+ source = ect::git+https://github.com/fhanau/Efficient-Compression-Tool.git#tag=v0.8.2
+ sha256sums = SKIP
+
+pkgname = ect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d2f8e6f4154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: William J. Bowman <aur@williamjbowman.com>
+
+pkgname=ect
+pkgver=0.8.2
+pkgrel=1
+pkgdesc='Efficient Compression Tool (or ECT) is a ++ file optimizer. It supports PNG, JPEG, GZIP and ZIP files.'
+url='https://github.com/fhanau/Efficient-Compression-Tool'
+arch=('i686' 'x86_64')
+license=('Apache2')
+source=("ect::git+https://github.com/fhanau/Efficient-Compression-Tool.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+makedepends=('nasm')
+
+prepare(){
+ cd "${srcdir}/${pkgname}/src"
+ git submodule update --init --recursive --recommend-shallow
+ cd mozjpeg
+ autoreconf -i
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/src"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/src"
+
+ PREFIX=/usr/ DESTDIR="${pkgdir}" make install
+ cd "${pkgdir}"/usr/bin
+
+ # Some things expect this to be an all-caps name
+ ln -s ect ECT
+}