summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2019-11-25 00:10:36 +0100
committerrevel2019-11-25 00:10:36 +0100
commit3d964094d86888a3c0fb5d155f83b42c23f2be23 (patch)
tree59fa4d30694d0232fbf6afadab01f87d6912294b
parent53b4af19723fc19587e622c8c875cae510d1547a (diff)
downloadaur-3d964094d86888a3c0fb5d155f83b42c23f2be23.tar.gz
- updated to version 1.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--build.patch11
-rw-r--r--edb.desktop4
-rw-r--r--plugin_path.patch12
5 files changed, 19 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0605a57f0102..9683083c2bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = edb-debugger
- pkgdesc = EDB (Evan's Debugger) is a Qt5 based binary mode debugger with the goal of having usability on par with OllyDbg.
- pkgver = 1.0.0
- pkgrel = 3
+ pkgdesc = EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg.
+ pkgver = 1.1.0
+ pkgrel = 1
url = http://www.codef00.com/projects#debugger
arch = i686
arch = x86_64
@@ -12,14 +12,10 @@ pkgbase = edb-debugger
depends = qt5-svg
depends = capstone>=3.0
optdepends = graphviz
- source = https://github.com/eteran/edb-debugger/releases/download/1.0.0/edb-debugger-1.0.0.tgz
+ source = https://github.com/eteran/edb-debugger/releases/download/1.1.0/edb-debugger-1.1.0.tgz
source = edb.desktop
- source = plugin_path.patch
- source = build.patch
- sha256sums = fab87541042df79ea63254e371d81b84d6b72f78141a6ab92512610ed2b7dfac
- sha256sums = e10b1f8ad676fe2037d62bc8600d8564772ad5e603b10a387b7375b878f60ae4
- sha256sums = 2b769b96d099036fcb606f32e52465ad6594c098d4060c9fb4d76e05d2f42cab
- sha256sums = 8f849b8469004b8607626b105e723240888fd3bd583dd2110a813cf11894a7ae
+ sha256sums = f13de8fd3f26fa1210fb0ff50ff756c2de8de51e75770a57aca35df06d6a0187
+ sha256sums = f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index 2cee7456ef30..b775d3e033d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: m4tx <m4tx@m4tx.p>
pkgname=edb-debugger
-pkgver=1.0.0
-pkgrel=3
-pkgdesc="EDB (Evan's Debugger) is a Qt5 based binary mode debugger with the goal of having usability on par with OllyDbg."
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
license=('GPL2')
@@ -13,30 +13,24 @@ depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz')
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
- 'edb.desktop'
- 'plugin_path.patch'
- 'build.patch')
-sha256sums=('fab87541042df79ea63254e371d81b84d6b72f78141a6ab92512610ed2b7dfac'
- 'e10b1f8ad676fe2037d62bc8600d8564772ad5e603b10a387b7375b878f60ae4'
- '2b769b96d099036fcb606f32e52465ad6594c098d4060c9fb4d76e05d2f42cab'
- '8f849b8469004b8607626b105e723240888fd3bd583dd2110a813cf11894a7ae')
+ 'edb.desktop')
+sha256sums=('f13de8fd3f26fa1210fb0ff50ff756c2de8de51e75770a57aca35df06d6a0187'
+ 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6')
prepare() {
- cd "edb-debugger-$pkgver"
- patch -p1 -i ../plugin_path.patch
- patch -p1 -i ../build.patch
+ cd "edb-debugger"
}
build() {
- cd "edb-debugger-$pkgver"
+ cd "edb-debugger"
[ ! -d build ] && mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DDEFAULT_PLUGIN_PATH="/usr/lib/edb/" ..
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" ..
make
}
package() {
- cd "edb-debugger-$pkgver"
+ cd "edb-debugger"
cd build
# install to pkg dir
@@ -54,3 +48,4 @@ package() {
cd ..
install -Dm644 edb.desktop "$pkgdir/usr/share/applications/edb.desktop"
}
+
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 5fc65508d993..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN 1/src/ByteShiftArray.cpp 2/src/ByteShiftArray.cpp
---- 1/src/ByteShiftArray.cpp 2018-05-05 00:41:48.000000000 +0200
-+++ 2/src/ByteShiftArray.cpp 2019-10-22 22:43:03.836923553 +0200
-@@ -17,6 +17,7 @@
- */
-
- #include "ByteShiftArray.h"
-+#include <climits>
-
- //------------------------------------------------------------------------------
- // Name: ByteShiftArray
diff --git a/edb.desktop b/edb.desktop
index 0256ea9ee8e8..8259bb9bd5cf 100644
--- a/edb.desktop
+++ b/edb.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=edb
-GenericName=edb debugger
-Comment=Qt5 based binary mode debugger
+GenericName="Evan's Debugger"
+Comment="edb is a cross platform x86/x86-64 debugger"
TryExec=edb
Exec=edb
Icon=edb
diff --git a/plugin_path.patch b/plugin_path.patch
deleted file mode 100644
index e9f980d89c38..000000000000
--- a/plugin_path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
---- 1/src/CMakeLists.txt 2018-05-05 00:41:48.000000000 +0200
-+++ 2/src/CMakeLists.txt 2018-05-17 01:02:06.731363180 +0200
-@@ -46,7 +46,7 @@
- set(GIT_BRANCH "Unknown")
- endif()
- add_definitions(-DGIT_BRANCH=${GIT_BRANCH})
--add_definitions(-DDEFAULT_PLUGIN_PATH=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb\")
-+add_definitions(-DDEFAULT_PLUGIN_PATH=\"${DEFAULT_PLUGIN_PATH}\")
-
- include_directories(
- "capstone-edb"