summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2020-12-14 06:15:47 +0100
committerrevel2020-12-14 06:15:47 +0100
commit94f01448697906ba5a200ff79ec9c8b84d1c1441 (patch)
tree9392d5ef6e0ddde5c9058b108dcf25fe17af751e
parent9c7b5501d1c08f1af6ce7a49ec5416a0b68aa283 (diff)
downloadaur-94f01448697906ba5a200ff79ec9c8b84d1c1441.tar.gz
- updated version to 1.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
-rw-r--r--build.patch11
-rw-r--r--plugin_path.patch12
4 files changed, 14 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304ff0f17c6a..a2a5d2c22213 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
pkgbase = edb-debugger
pkgdesc = EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg.
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.3.0
+ pkgrel = 1
url = http://www.codef00.com/projects#debugger
arch = i686
arch = x86_64
license = GPL2
makedepends = boost>=1.35.0
makedepends = cmake
- depends = qt5-xmlpatterns
- depends = qt5-svg
+ depends = qt5-xmlpatterns>=5.2
+ depends = qt5-svg>=5.2
depends = capstone>=3.0
- optdepends = graphviz
- source = https://github.com/eteran/edb-debugger/releases/download/1.2.0/edb-debugger-1.2.0.tgz
+ optdepends = graphviz>=2.38.0
+ source = https://github.com/eteran/edb-debugger/releases/download/1.3.0/edb-debugger-1.3.0.tgz
source = edb.desktop
- source = plugin_path.patch
- source = build.patch
- sha256sums = 96f8ee00c5983e6a4e108a0d738464e8b74da187018229334b498c80e7fe4917
+ sha256sums = 86df4a0940a39c1480a6fc789f167f94e87a7a330f2d8163fe871f42c754afe8
sha256sums = f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6
- sha256sums = f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10
- sha256sums = 016d136ccd85fde635d3c30e25106ca7717844140887bc830e6fae9708a976e2
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index 503e2fe998f4..7a35f6c1af1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,22 @@
# Contributor: m4tx <m4tx@m4tx.p>
pkgname=edb-debugger
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
license=('GPL2')
-depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
+depends=('qt5-xmlpatterns>=5.2' 'qt5-svg>=5.2' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
-optdepends=('graphviz')
+optdepends=('graphviz>=2.38.0')
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
- 'edb.desktop'
- 'plugin_path.patch'
- 'build.patch')
-sha256sums=('96f8ee00c5983e6a4e108a0d738464e8b74da187018229334b498c80e7fe4917'
- 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6'
- 'f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10'
- '016d136ccd85fde635d3c30e25106ca7717844140887bc830e6fae9708a976e2')
+ 'edb.desktop')
+sha256sums=('86df4a0940a39c1480a6fc789f167f94e87a7a330f2d8163fe871f42c754afe8'
+ 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6')
prepare() {
cd "edb-debugger"
- patch -p1 -i ../plugin_path.patch
- patch -p1 -i ../build.patch
}
build() {
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 9a1d8279cf8d..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --color -ruN 1/src/widgets/QDisassemblyView.h 2/src/widgets/QDisassemblyView.h
---- 1/src/widgets/QDisassemblyView.h 2020-04-10 21:07:19.000000000 +0200
-+++ 2/src/widgets/QDisassemblyView.h 2020-10-13 10:44:21.518521560 +0200
-@@ -25,6 +25,7 @@
- #include <QAbstractScrollArea>
- #include <QAbstractSlider>
- #include <QCache>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QSvgRenderer>
-
diff --git a/plugin_path.patch b/plugin_path.patch
deleted file mode 100644
index 3c97b74c691c..000000000000
--- a/plugin_path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
---- 1/src/CMakeLists.txt 2019-11-24 04:07:27.000000000 +0100
-+++ 2/src/CMakeLists.txt 2019-12-17 03:06:05.118631427 +0100
-@@ -219,7 +219,7 @@
-
- target_compile_definitions(edb PRIVATE
- -DGIT_BRANCH=${GIT_BRANCH}
-- -DDEFAULT_PLUGIN_PATH=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb\"
-+ -DDEFAULT_PLUGIN_PATH=\"${DEFAULT_PLUGIN_PATH}\"
- )
-
- target_link_libraries(edb