summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2020-10-13 11:04:46 +0200
committerrevel2020-10-13 11:04:46 +0200
commit9c7b5501d1c08f1af6ce7a49ec5416a0b68aa283 (patch)
tree5d7428e9c21e239af7572255d33d24e177d1178d
parent96755816635e5dc514bf94cbab2bbcfa8e43df55 (diff)
downloadaur-9c7b5501d1c08f1af6ce7a49ec5416a0b68aa283.tar.gz
- fixes QPainterPath related build error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--build.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5aa9639f494..304ff0f17c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = edb-debugger
pkgdesc = EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg.
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.codef00.com/projects#debugger
arch = i686
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = edb-debugger
source = https://github.com/eteran/edb-debugger/releases/download/1.2.0/edb-debugger-1.2.0.tgz
source = edb.desktop
source = plugin_path.patch
+ source = build.patch
sha256sums = 96f8ee00c5983e6a4e108a0d738464e8b74da187018229334b498c80e7fe4917
sha256sums = f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6
sha256sums = f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10
+ sha256sums = 016d136ccd85fde635d3c30e25106ca7717844140887bc830e6fae9708a976e2
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index d5760d4e077b..503e2fe998f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=edb-debugger
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
@@ -14,14 +14,17 @@ makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz')
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
'edb.desktop'
- 'plugin_path.patch')
+ 'plugin_path.patch'
+ 'build.patch')
sha256sums=('96f8ee00c5983e6a4e108a0d738464e8b74da187018229334b498c80e7fe4917'
'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6'
- 'f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10')
+ 'f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10'
+ '016d136ccd85fde635d3c30e25106ca7717844140887bc830e6fae9708a976e2')
prepare() {
cd "edb-debugger"
patch -p1 -i ../plugin_path.patch
+ patch -p1 -i ../build.patch
}
build() {
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..9a1d8279cf8d
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,11 @@
+diff --color -ruN 1/src/widgets/QDisassemblyView.h 2/src/widgets/QDisassemblyView.h
+--- 1/src/widgets/QDisassemblyView.h 2020-04-10 21:07:19.000000000 +0200
++++ 2/src/widgets/QDisassemblyView.h 2020-10-13 10:44:21.518521560 +0200
+@@ -25,6 +25,7 @@
+ #include <QAbstractScrollArea>
+ #include <QAbstractSlider>
+ #include <QCache>
++#include <QPainterPath>
+ #include <QPixmap>
+ #include <QSvgRenderer>
+