summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2015-06-21 16:58:33 +0200
committerrevel2015-06-21 16:58:33 +0200
commite643a62ddce459c687c00fa7e3f92bb7c2137ce2 (patch)
treeacd1ed4c3f7a0211a827625cb53b474cb5246f77
downloadaur-e643a62ddce459c687c00fa7e3f92bb7c2137ce2.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--edb.desktop16
-rw-r--r--edb.install32
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2776f0cf02d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = edb-debugger
+ pkgdesc = EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg.
+ pkgver = 0.9.20
+ pkgrel = 1
+ url = http://www.codef00.com/projects#debugger
+ install = edb.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = boost>=1.35.0
+ depends = qt4>=4.6
+ source = http://www.codef00.com/projects/debugger-0.9.20.tgz
+ source = edb.desktop
+ md5sums = 5916d415f598fae8632dd763f58e11d1
+ md5sums = 8844cd95efef848f8f4a444259491961
+ sha256sums = fd4ebdf8a30ace88395b7b61407fd264cb3919d97368d4932201f0fed6b7ef4d
+ sha256sums = af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132
+
+pkgname = edb-debugger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d71dd83ed0fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: revel <revelΘmuub·net>
+# Contributor: shild <sxp@bk.ru>
+
+pkgname=edb-debugger
+pkgver=0.9.20
+pkgrel=1
+pkgdesc="EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg."
+arch=('i686' 'x86_64')
+url='http://www.codef00.com/projects#debugger'
+license=('GPL2')
+depends=('qt4>=4.6')
+makedepends=('boost>=1.35.0')
+install=edb.install
+source=("http://www.codef00.com/projects/debugger-$pkgver.tgz"
+ 'edb.desktop')
+md5sums=('5916d415f598fae8632dd763f58e11d1'
+ '8844cd95efef848f8f4a444259491961')
+sha256sums=('fd4ebdf8a30ace88395b7b61407fd264cb3919d97368d4932201f0fed6b7ef4d'
+ 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132')
+
+build() {
+ cd "debugger"
+
+ qmake-qt4 -makefile DEFAULT_PLUGIN_PATH="/usr/lib/edb/"
+ make
+}
+
+package() {
+ cd "debugger"
+
+ # install to pkg dir
+ make INSTALL_ROOT="$pkgdir/usr/" install
+
+ # correct /usr/lib64 -> /usr/lib on x86_64
+ [ "$CARCH" = "x86_64" ] && (mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib")
+
+ # icons
+ install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/pixmaps/edb.png"
+ install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/edb.png"
+
+ # install desktop file
+ cd ..
+ install -Dm644 edb.desktop "$pkgdir/usr/share/applications/edb.desktop"
+}
diff --git a/edb.desktop b/edb.desktop
new file mode 100644
index 000000000000..fdcc2a56a85a
--- /dev/null
+++ b/edb.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=Evan's Debugger
+GenericName=Debugger
+Comment=QT4 based binary mode debugger
+TryExec=edb
+Exec=edb
+Terminal=false
+Type=Application
+Icon=edb
+Categories=Application;Development;Qt;Debugger;
+Actions=Debug
+MimeType=application/x-executable
+
+[Desktop Action Debug]
+Exec=edb --run %f
+Name=Evan's Debugger (debug with)
diff --git a/edb.install b/edb.install
new file mode 100644
index 000000000000..251231db5e93
--- /dev/null
+++ b/edb.install
@@ -0,0 +1,32 @@
+post_install() {
+# echo "===="
+# echo "NOTE"
+# echo "===="
+# echo "* Since the tools that ./edb_make_symbolmap is dependant on are not uniform"
+# echo " across all the platforms that I intend to support. I have built symbol"
+# echo " file generation into edb directly. Running './edb --symbols <filename>' will"
+# echo " create a symbol file in the same format as the old script. For now, ELF is the"
+# echo " only supported format but more will be added as needed. This also means"
+# echo " that future versions of edb will be able to generate symbols as needed"
+# echo " if no symbol file is provided, making things \"just work\" more often."
+# echo "==="
+# echo " EBD's plugins are installed by default into /usr/lib/edb."
+# echo " If you have previously used EDB and have it set to look in a"
+# echo " different directory, then you will need to adjust this. Also"
+# echo " EDB looks for plugins in the current working directory as well"
+# echo " as the directory specified in the options, so that unpriviledged"
+# echo " users can use plugins not installed system wide."
+# echo ""
+
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}