summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-12 09:54:02 +0800
committermaz-12015-10-12 09:54:02 +0800
commita217046f0ea54b0c301905a667e110d64a83c979 (patch)
treea067714a63a56f2e67462c7d540a8f38c85a7e5a
downloadaur-a217046f0ea54b0c301905a667e110d64a83c979.tar.gz
initial
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD60
-rw-r--r--edb.desktop16
-rw-r--r--edb.install32
4 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2be02531e87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = edb-debugger-git
+ pkgdesc = EDB (Evan's Debugger) is a binary mode debugger with the goal of having usability on par with OllyDbg. Git version
+ pkgver = r906.863ea6a
+ pkgrel = 1
+ url = http://www.codef00.com/projects#debugger
+ install = edb.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = boost>=1.35.0
+ depends = qt5-base
+ depends = capstone
+ source = git+https://github.com/eteran/edb-debugger.git
+ source = git+https://github.com/eteran/qhexview.git
+ source = edb.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 8844cd95efef848f8f4a444259491961
+
+pkgname = edb-debugger-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..344109a1befa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: maz_1 <ohmygod19993 at gmail dot com>
+
+_pkgname=edb-debugger
+pkgname=$_pkgname-git
+pkgver=r906.863ea6a
+pkgrel=1
+pkgdesc="EDB (Evan's Debugger) is a binary mode debugger with the goal of having usability on par with OllyDbg. Git version"
+arch=('i686' 'x86_64')
+url='http://www.codef00.com/projects#debugger'
+license=('GPL2')
+depends=('qt5-base' 'capstone')
+makedepends=('boost>=1.35.0')
+install=edb.install
+source=("git+https://github.com/eteran/edb-debugger.git"
+ "git+https://github.com/eteran/qhexview.git"
+ 'edb.desktop')
+md5sums=('SKIP'
+ 'SKIP'
+ '8844cd95efef848f8f4a444259491961')
+
+pkgver() {
+ cd $_pkgname
+
+ if git_version=$( git describe --long --tags 2>/dev/null ); then
+ IFS='-' read last_tag tag_rev commit <<< "$git_version"
+ printf '%s.r%s.%s' "$last_tag" "$tag_rev" "$commit"
+ else
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ fi
+}
+prepare() {
+ cd $_pkgname/src
+ git submodule init qhexview
+ git config submodule.qhexview.url ../../qhexview
+ git submodule update qhexview
+}
+build() {
+ cd $_pkgname
+ sed -i "s:/usr/local:/usr:g" common.pri
+ qmake-qt5 -makefile DEFAULT_PLUGIN_PATH="/usr/lib/edb/"
+ make -j4
+}
+
+package() {
+ cd $_pkgname
+
+ # install to pkg dir
+ make INSTALL_ROOT="$pkgdir" install
+
+ # correct /usr/lib64 -> /usr/lib on x86_64
+ [ "$CARCH" = "x86_64" ] && (mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib")
+
+ # icons
+ install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/pixmaps/edb.png"
+ install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/edb.png"
+
+ # install desktop file
+ cd ..
+ install -Dm644 edb.desktop "$pkgdir/usr/share/applications/edb.desktop"
+}
diff --git a/edb.desktop b/edb.desktop
new file mode 100644
index 000000000000..fdcc2a56a85a
--- /dev/null
+++ b/edb.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=Evan's Debugger
+GenericName=Debugger
+Comment=QT4 based binary mode debugger
+TryExec=edb
+Exec=edb
+Terminal=false
+Type=Application
+Icon=edb
+Categories=Application;Development;Qt;Debugger;
+Actions=Debug
+MimeType=application/x-executable
+
+[Desktop Action Debug]
+Exec=edb --run %f
+Name=Evan's Debugger (debug with)
diff --git a/edb.install b/edb.install
new file mode 100644
index 000000000000..251231db5e93
--- /dev/null
+++ b/edb.install
@@ -0,0 +1,32 @@
+post_install() {
+# echo "===="
+# echo "NOTE"
+# echo "===="
+# echo "* Since the tools that ./edb_make_symbolmap is dependant on are not uniform"
+# echo " across all the platforms that I intend to support. I have built symbol"
+# echo " file generation into edb directly. Running './edb --symbols <filename>' will"
+# echo " create a symbol file in the same format as the old script. For now, ELF is the"
+# echo " only supported format but more will be added as needed. This also means"
+# echo " that future versions of edb will be able to generate symbols as needed"
+# echo " if no symbol file is provided, making things \"just work\" more often."
+# echo "==="
+# echo " EBD's plugins are installed by default into /usr/lib/edb."
+# echo " If you have previously used EDB and have it set to look in a"
+# echo " different directory, then you will need to adjust this. Also"
+# echo " EDB looks for plugins in the current working directory as well"
+# echo " as the directory specified in the options, so that unpriviledged"
+# echo " users can use plugins not installed system wide."
+# echo ""
+
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}