summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-08-26 02:31:34 +0200
committerMladen Milinkovic2019-08-26 14:45:08 +0200
commitb2688dc1bc391879524d47fb4bba230fccf80054 (patch)
treead8dc625eb72ec8007f89e63e697690696eeb51b
parentc4867869f312389ce5f4980bdc44e58b98d9a25d (diff)
downloadaur-b2688dc1bc391879524d47fb4bba230fccf80054.tar.gz
Updated PKGBUILD from https://gist.github.com/tonylambiris/43816f9c77d80d8450b0d28e06cabe2c
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD36
-rw-r--r--edb.install32
4 files changed, 27 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d58bb586a27..117c5acee547 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = edb-debugger-git
pkgdesc = EDB (Evan's Debugger) is a binary mode debugger with the goal of having usability on par with OllyDbg. Git version
- pkgver = r906.863ea6a
+ pkgver = 1.0.0.r368.gf1b6efe8
pkgrel = 1
url = http://www.codef00.com/projects#debugger
- install = edb.install
arch = i686
arch = x86_64
license = GPL2
@@ -12,11 +11,9 @@ pkgbase = edb-debugger-git
depends = capstone
depends = qt5-xmlpatterns
source = git+https://github.com/eteran/edb-debugger.git
- source = git+https://github.com/eteran/qhexview.git
source = edb.desktop
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 8844cd95efef848f8f4a444259491961
+ sha256sums = SKIP
+ sha256sums = af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132
pkgname = edb-debugger-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c98cdbbd9a8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.log
+*.sig
+*.tar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 6f36a62f545a..82f19502ed0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=edb-debugger
pkgname=$_pkgname-git
-pkgver=r906.863ea6a
+pkgver=1.0.0.r368.gf1b6efe8
pkgrel=1
pkgdesc="EDB (Evan's Debugger) is a binary mode debugger with the goal of having usability on par with OllyDbg. Git version"
arch=('i686' 'x86_64')
@@ -10,13 +10,10 @@ url='http://www.codef00.com/projects#debugger'
license=('GPL2')
depends=('qt5-base' 'capstone' 'qt5-xmlpatterns')
makedepends=('boost>=1.35.0')
-install=edb.install
source=("git+https://github.com/eteran/edb-debugger.git"
- "git+https://github.com/eteran/qhexview.git"
'edb.desktop')
-md5sums=('SKIP'
- 'SKIP'
- '8844cd95efef848f8f4a444259491961')
+sha256sums=('SKIP'
+ 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132')
pkgver() {
cd $_pkgname
@@ -28,33 +25,36 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
fi
}
+
prepare() {
- cd $_pkgname/src
- git submodule init qhexview
- git config submodule.qhexview.url ../../qhexview
- git submodule update qhexview
+ cd $_pkgname
+
+ git submodule update --init --recursive
}
+
build() {
cd $_pkgname
- sed -i "s:/usr/local:/usr:g" common.pri
- qmake-qt5 -makefile DEFAULT_PLUGIN_PATH="/usr/lib/edb/"
+
+ mkdir -p build
+ cd build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
cd $_pkgname
+ cd build
# install to pkg dir
- make INSTALL_ROOT="$pkgdir" install
-
- # correct /usr/lib64 -> /usr/lib on x86_64
- [ "$CARCH" = "x86_64" ] && (mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib")
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ cd ..
# icons
install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/pixmaps/edb.png"
install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/edb.png"
# install desktop file
- cd ..
- install -Dm644 edb.desktop "$pkgdir/usr/share/applications/edb.desktop"
+ install -Dm644 "$srcdir/edb.desktop" "$pkgdir/usr/share/applications/edb.desktop"
}
diff --git a/edb.install b/edb.install
deleted file mode 100644
index 251231db5e93..000000000000
--- a/edb.install
+++ /dev/null
@@ -1,32 +0,0 @@
-post_install() {
-# echo "===="
-# echo "NOTE"
-# echo "===="
-# echo "* Since the tools that ./edb_make_symbolmap is dependant on are not uniform"
-# echo " across all the platforms that I intend to support. I have built symbol"
-# echo " file generation into edb directly. Running './edb --symbols <filename>' will"
-# echo " create a symbol file in the same format as the old script. For now, ELF is the"
-# echo " only supported format but more will be added as needed. This also means"
-# echo " that future versions of edb will be able to generate symbols as needed"
-# echo " if no symbol file is provided, making things \"just work\" more often."
-# echo "==="
-# echo " EBD's plugins are installed by default into /usr/lib/edb."
-# echo " If you have previously used EDB and have it set to look in a"
-# echo " different directory, then you will need to adjust this. Also"
-# echo " EDB looks for plugins in the current working directory as well"
-# echo " as the directory specified in the options, so that unpriviledged"
-# echo " users can use plugins not installed system wide."
-# echo ""
-
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}