summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-09 15:34:07 +0300
committerDimitris Kiziridis2020-04-09 15:34:07 +0300
commit4e9ecdfa13e3fd5294d5f1871c46a1437420ace2 (patch)
tree9ae1b2f783faf6fcedc2294d02ba5389c7d9db23
downloadaur-4e9ecdfa13e3fd5294d5f1871c46a1437420ace2.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fdf058fa816
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = edcount
+ pkgdesc = Estimate distinct count of values from standard input. Provides a very fast way to perform unique count estimates on the command line
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/haroldfreeman/edcount
+ arch = x86_64
+ license = GPL-3.0
+ source = https://github.com/haroldfreeman/edcount/archive/v1.2.0.tar.gz
+ md5sums = 99fe6c46d4c12494af3ff78c96ebea4e
+
+pkgname = edcount
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..804fc9b08879
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=edcount
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Estimate distinct count of values from standard input. Provides a very fast way to perform unique count estimates on the command line'
+arch=('x86_64')
+url='https://github.com/haroldfreeman/edcount'
+license=('GPL-3.0')
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('99fe6c46d4c12494af3ff78c96ebea4e')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -i
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file