summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEddie.website2018-06-04 14:34:49 +0200
committerEddie.website2018-06-04 14:34:49 +0200
commit5f7ef2b0d676c46933ed8625ea65eb12a405cf84 (patch)
tree7231215bad6c25cd3b393f472c026d47ee039843
downloadaur-5f7ef2b0d676c46933ed8625ea65eb12a405cf84.tar.gz
ready
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD87
-rw-r--r--eddie-ui-git.install30
3 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9178556844e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = eddie-ui-git
+ pkgdesc = Eddie - OpenVPN UI
+ pkgver = 2.14.5
+ pkgrel = 1
+ url = https://eddie.website
+ install = eddie-ui-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = mono
+ depends = openvpn
+ depends = sudo
+ depends = desktop-file-utils
+ depends = libnotify
+ depends = libappindicator-gtk2
+ optdepends = stunnel: VPN over SSL
+ optdepends = openssh: VPN over SSH
+ provides = eddie-ui
+ conflicts = airvpn
+ conflicts = airvpn-beta-bin
+ conflicts = airvpn-git
+ source = git+https://github.com/AirVPN/Eddie.git
+ sha1sums = SKIP
+
+pkgname = eddie-ui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f816fa30200c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Eddie.website <maintainer@eddie.website>
+# Based on work by Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ> and Beini <bane aτ iki dot fi>
+
+# This PKGUILD it's based on the latest GitHub commit.
+# Pending work: man & changelog files generated automatically.
+
+pkgname=eddie-ui-git
+pkgver=2.14.5
+pkgrel=1
+pkgdesc='Eddie - OpenVPN UI'
+arch=('i686' 'x86_64')
+url=https://eddie.website
+license=(GPL3)
+depends=(mono openvpn sudo desktop-file-utils libnotify libappindicator-gtk2)
+optdepends=('stunnel: VPN over SSL' 'openssh: VPN over SSH')
+makedepends=('cmake')
+provides=('eddie-ui')
+conflicts=('airvpn' 'airvpn-beta-bin' 'airvpn-git')
+install=eddie-ui-git.install
+source=('git+https://github.com/AirVPN/Eddie.git')
+sha1sums=('SKIP')
+
+case "$CARCH" in
+ i686) _pkgarch="x86"
+ ;;
+ x86_64) _pkgarch="x64"
+ ;;
+esac
+
+build() {
+ export TERM=xterm # Fix Mono bug "Magic number is wrong".
+
+ # Compile C# sources
+ cd "Eddie"
+ xbuild /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie2.linux.sln
+
+ # Compile C sources (Tray)
+ cd src/UI.GTK.Linux.Tray
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_LIBRARY_OUTPUT_DIRECTORY=.
+ make
+ strip -S --strip-unneeded -o eddie-tray-strip eddie_tray
+ cd ../..
+
+ # Compile C sources (Linux Native)
+ cd src/Lib.Platform.Linux.Native
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_LIBRARY_OUTPUT_DIRECTORY=.
+ make
+ strip -S --strip-unneeded -o libLib.Platform.Linux.Native.strip.so libLib.Platform.Linux.Native.so
+ cd ../..
+}
+
+package() {
+ cd "Eddie"
+ install -Dm755 "src/App.Forms.Linux/bin/$_pkgarch/Release/App.Forms.Linux.exe" "$pkgdir/usr/lib/eddie-ui/Eddie-UI.exe"
+ install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Common.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Common.dll"
+ install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Core.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Core.dll"
+ install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Forms.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Forms.dll"
+ install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Platform.Linux.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Platform.Linux.dll"
+ install -Dm644 "src/Lib.Platform.Linux.Native/libLib.Platform.Linux.Native.strip.so" "$pkgdir/usr/lib/eddie-ui/libLib.Platform.Linux.Native.so"
+ install -Dm755 "src/UI.GTK.Linux.Tray/eddie-tray-strip" "$pkgdir/usr/lib/eddie-ui/eddie-tray"
+ install -Dm755 "deploy/linux_$_pkgarch/update-resolv-conf" "$pkgdir/usr/lib/eddie-ui/update-resolv-conf"
+ install -Dm755 "resources/debian/usr/bin/eddie-ui" "$pkgdir/usr/bin/eddie-ui"
+ install -Dm644 "common/cacert.pem" "$pkgdir/usr/share/eddie-ui/cacert.pem"
+ install -Dm644 "common/icon.png" "$pkgdir/usr/share/eddie-ui/icon.png"
+ install -Dm644 "common/icon_gray.png" "$pkgdir/usr/share/eddie-ui/icon_gray.png"
+ # install -Dm644 "resources/arch/usr/share/doc/eddie-ui/changelog.Debian.gz" "$pkgdir/usr/share/doc/eddie-ui/changelog.gz" # TOFIX: Missing changelog generation
+ install -Dm644 "resources/arch/usr/share/doc/eddie-ui/copyright" "$pkgdir/usr/share/doc/eddie-ui/copyright"
+ # install -Dm644 "resources/arch/usr/share/man/man8/eddie-ui.8.gz" "$pkgdir/usr/share/man/man1/eddie-ui.8.gz" # TOFIX: Missing man generation
+ install -Dm644 "resources/arch/usr/share/polkit-1/actions/org.airvpn.eddie.ui.policy" "$pkgdir/usr/share/polkit-1/actions/org.airvpn.eddie.ui.policy"
+ install -Dm644 "resources/arch/usr/share/pixmaps/eddie-ui.png" "$pkgdir/usr/share/pixmaps/eddie-ui.png"
+
+ ## Fix .desktop file for KDE
+ _desktop_session=$(printf "%s" "$DESKTOP_SESSION" | awk -F "/" '{print $NF}')
+ if [ "$_desktop_session" = "plasma" ]; then
+ msg2 "Installing desktop file for KDE..."
+ desktop-file-install -m 644 --set-comment="OpenVPN UI" \
+ --dir="$pkgdir/usr/share/applications/" \
+ --set-icon="/usr/share/pixmaps/eddie-ui.png" \
+ "resources/opensuse/usr/share/applications/eddie-ui.desktop"
+ else
+ msg2 "Installing desktop file..."
+ desktop-file-install -m 644 --set-comment="OpenVPN UI" \
+ --dir="$pkgdir/usr/share/applications/" \
+ "resources/opensuse/usr/share/applications/eddie-ui.desktop"
+ fi
+}
+
diff --git a/eddie-ui-git.install b/eddie-ui-git.install
new file mode 100644
index 000000000000..2a4b46bb2950
--- /dev/null
+++ b/eddie-ui-git.install
@@ -0,0 +1,30 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _update
+}