summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheunpleasantowl2018-10-07 01:31:27 -0400
committertheunpleasantowl2018-10-07 01:31:27 -0400
commitd7dc19721dd0404435aab5236e3fa401206fd124 (patch)
treefed9ff1551f1b35a18a5fbcf45bc48676842e41b
downloadaur-d7dc19721dd0404435aab5236e3fa401206fd124.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f5e2b9d4488
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = edenmath.app
+ pkgdesc = Scientific calculator originally written for Mac OSX & ported to GNUstep
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://www.eskimo.com/~pburns/EdenMath/files/EdenMath_GNUstep-1.1.1.tar.gz
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ source = https://www.eskimo.com/~pburns/EdenMath/files/EdenMath_GNUstep-1.1.1.tar.gz
+ sha256sums = fb149a898bae0f08cb86efa388f2847c1ddfe6a6738f4ee6de7eeaa2c9cc444f
+
+pkgname = edenmath.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38913a7abe35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+pkgname=edenmath.app
+_pkgname=EdenMath
+pkgrel=1
+pkgver=1.1.1
+pkgdesc="Scientific calculator originally written for Mac OSX & ported to GNUstep"
+arch=('i686' 'x86_64')
+url="https://www.eskimo.com/~pburns/EdenMath/files/EdenMath_GNUstep-1.1.1.tar.gz"
+license=('GPL')
+depends=('gnustep-base' 'gnustep-gui')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("https://www.eskimo.com/~pburns/EdenMath/files/EdenMath_GNUstep-1.1.1.tar.gz")
+sha256sums=('fb149a898bae0f08cb86efa388f2847c1ddfe6a6738f4ee6de7eeaa2c9cc444f')
+
+build() {
+ cd "EdenMath_GNUstep-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "EdenMath_GNUstep-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}