summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitSquared2019-09-04 18:47:58 +0200
committerGitSquared2019-09-04 18:47:58 +0200
commitddc8a13ab2cc17a231817b95a49919d149583a25 (patch)
treea62c82886531b97918ad66d19753b8db1bfa4ac8
parentdd325ef3df28c69957f4a72a01d3b313d830a238 (diff)
downloadaur-ddc8a13ab2cc17a231817b95a49919d149583a25.tar.gz
Fix package versioning
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82521da8ab37..fac04529ed50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' || echo 1.0.0
+ echo $(head -n 4 package.json | tail -n 1 | sed 's/ "version": "//;s/",//;s/-/./g').$(git log -n 1 --oneline | head -c 7)
}
build() {