summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 09:10:47 +0200
committeraksr2015-06-28 09:10:47 +0200
commit33c1499b49787b90a12a03d6b1436d1dc1946c01 (patch)
treed899efa5efb8801223905db8ba9021c3836f83e8
downloadaur-33c1499b49787b90a12a03d6b1436d1dc1946c01.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
-rw-r--r--echo.install8
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a428013082
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = edit-git
+ pkgdesc = An experimental text editor, a relaxing mix of vi & acme.
+ pkgver = 0.r309.b1634e6
+ pkgrel = 1
+ url = http://c9x.me/edit/
+ install = echo.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ makedepends = texlive-bin
+ makedepends = texlive-core
+ source = edit-git::git://c9x.me/ed.git
+ md5sums = SKIP
+
+pkgname = edit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..780d494c7b25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=edit-git
+pkgver=0.r309.b1634e6
+pkgrel=1
+epoch=
+pkgdesc="An experimental text editor, a relaxing mix of vi & acme."
+arch=('i686' 'x86_64')
+url="http://c9x.me/edit/"
+license=('unknown')
+groups=()
+depends=('')
+makedepends=('git' 'texlive-bin' 'texlive-core')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=echo.install
+source=("$pkgname::git://c9x.me/ed.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+ cweave vicmd; tex vicmd; pdftex vicmd
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ ## Renamed to Edit to avoid conflict with vi package.
+ install -Dm755 obj/edit $pkgdir/usr/bin/Edit
+ install -Dm644 vicmd.dvi $pkgdir/usr/share/doc/$pkgname/vicmd.dvi
+ install -Dm644 vicmd.pdf $pkgdir/usr/share/doc/$pkgname/vicmd.pdf
+}
+
diff --git a/echo.install b/echo.install
new file mode 100644
index 000000000000..59fd58c97247
--- /dev/null
+++ b/echo.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ">>> Renamed to Edit to avoid conflict with vi package."
+}
+
+post_upgrade() {
+ post_install
+}
+