summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax StrĂ¼bing2019-08-18 18:30:22 +0200
committerMax StrĂ¼bing2019-08-18 18:30:22 +0200
commit7ebfa3b0849d7ddd3e2e4a1da5b321e0ad5ec78b (patch)
tree5dda108eafeb3dce61b5977b0da4193bfa0e5869
downloadaur-7ebfa3b0849d7ddd3e2e4a1da5b321e0ad5ec78b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..563a377601b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = editorconfig-checker-git
+ pkgdesc = A tool to verify that your files are in harmony with your .editorconfig
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/editorconfig-checker/editorconfig-checker
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = ec
+ source = git+https://github.com/editorconfig-checker/editorconfig-checker
+ md5sums = SKIP
+
+pkgname = editorconfig-checker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f539f63d8944
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Max Struebing <mxstrbng@gmail.com>
+
+pkgname=editorconfig-checker-git
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A tool to verify that your files are in harmony with your .editorconfig"
+arch=(any)
+url="https://github.com/editorconfig-checker/editorconfig-checker"
+license=('MIT')
+depends=()
+makedepends=('git' 'go')
+source=("git+$url")
+md5sums=('SKIP')
+provides=('ec')
+
+pkgver() {
+ cd "$srcdir/editorconfig-checker" || exit
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//g'
+}
+
+build() {
+ cd "$srcdir/editorconfig-checker"
+ go get -u github.com/editorconfig-checker/editorconfig-checker
+ make build
+}
+
+package() {
+ cd "$srcdir/ediroconfig-checker/bin" || exit
+ install -Dm755 ec "$pkgdir/usr/bin/editorconfig-checker"
+ cd "$srcdir/ediroconfig-checker" || exit
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/ediroconfig-checker/LICENSE"
+}