summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Richards2015-08-06 11:55:21 -0400
committerTom Richards2015-08-06 11:55:21 -0400
commit2927dd5b1b439e1574c8bd41cab68ea67ac0ccd4 (patch)
treec7f340160ef7ee9131d7bdfd87b4732c94001c55
downloadaur-2927dd5b1b439e1574c8bd41cab68ea67ac0ccd4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD29
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c487cab595c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = editorconfig-gedit
+ pkgdesc = EditorConfig plugin for gedit
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = http://editorconfig.org
+ arch = any
+ license = BSD
+ depends = gedit
+ depends = python-editorconfig
+ source = https://github.com/editorconfig/editorconfig-gedit/archive/v0.5.3.tar.gz
+ sha256sums = d6c88a400bfbab36355ab6674db65c0d4997c970fc58a08752c1b331bea625e3
+
+pkgname = editorconfig-gedit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aa5e44415403
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!LICENSE
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7e11b2109176
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Tom Richards
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc03b39d1503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tom Richards <tom@tomrichards.net>
+# https://github.com/t-richards/aur-editorconfig-gedit
+pkgname=editorconfig-gedit
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="EditorConfig plugin for gedit"
+arch=('any')
+url="http://editorconfig.org"
+license=('BSD')
+depends=('gedit' 'python-editorconfig')
+
+source=("https://github.com/editorconfig/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('d6c88a400bfbab36355ab6674db65c0d4997c970fc58a08752c1b331bea625e3')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ # Plugin
+ _installdir="$pkgdir/usr/lib/gedit/plugins"
+ mkdir -p "$_installdir"
+ cp -r editorconfig_plugin/ "$_installdir"
+ cp editorconfig.plugin "$_installdir"
+ cp editorconfig_gedit3.py "$_installdir"
+ sed -i 's/python/python3/' "$_installdir/editorconfig.plugin"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+