summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-03-19 16:57:38 +0800
committerChocobo12017-03-19 16:57:47 +0800
commit91cfb6252377235286a18d067c154377f12dcd3d (patch)
treed270848c2da7f3fe92b726ed0df84795a9f3f312
downloadaur-91cfb6252377235286a18d067c154377f12dcd3d.tar.gz
newpkg: editorconfig-gedit-git 0.5.3.r8.g53d469c-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88b53db39796
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = editorconfig-gedit-git
+ pkgdesc = EditorConfig plugin for gedit
+ pkgver = 0.5.3.r8.g53d469c
+ pkgrel = 1
+ url = http://editorconfig.org/
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = gedit
+ depends = python-editorconfig
+ provides = editorconfig-gedit
+ conflicts = editorconfig-gedit
+ source = git+https://github.com/editorconfig/editorconfig-gedit.git
+ sha256sums = SKIP
+
+pkgname = editorconfig-gedit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a2727762815
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=editorconfig-gedit-git
+pkgver=0.5.3.r8.g53d469c
+pkgrel=1
+pkgdesc="EditorConfig plugin for gedit"
+arch=('any')
+url="http://editorconfig.org/"
+license=('BSD')
+depends=('gedit' 'python-editorconfig')
+makedepends=('git')
+provides=('editorconfig-gedit')
+conflicts=('editorconfig-gedit')
+source=("git+https://github.com/editorconfig/editorconfig-gedit.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "editorconfig-gedit"
+
+ git describe --long --tags | sed 's/^[A-Za-z]*//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "editorconfig-gedit"
+
+ _installdir="$pkgdir/usr/lib/gedit/plugins"
+ mkdir -p "$_installdir"
+
+ cp -r "editorconfig_plugin/" "$_installdir"
+ cp "editorconfig.plugin" "$_installdir"
+ cp "editorconfig_gedit3.py" "$_installdir"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/editorconfig-gedit/LICENSE"
+}