summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-08 00:35:28 +0200
committerhaawda2018-04-08 00:35:28 +0200
commit6bd7ccdd33ad6cbd29236f57de40530adcf74bf0 (patch)
tree1f5508316be169fe37d9bcdc9a202017d2ef7155
downloadaur-6bd7ccdd33ad6cbd29236f57de40530adcf74bf0.tar.gz
reupload, as the official wxpython packages were refactored
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--editra.desktop11
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66efbdc1dd29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Apr 7 22:35:01 UTC 2018
+pkgbase = editra
+ pkgdesc = Multi-platform text editor with features that aid in code development
+ pkgver = 0.7.20
+ pkgrel = 1
+ url = http://editra.org/
+ arch = any
+ license = custom:wxWindows
+ depends = python2-wxpython3
+ depends = python2-distribute
+ depends = desktop-file-utils
+ source = http://editra.org/uploads/src/Editra-0.7.20.tar.gz
+ source = editra.desktop
+ md5sums = a52c6b3d703f98e0390aa7b44f991616
+ md5sums = 6082f8d4bf1650af8ce87c6b3d38053b
+
+pkgname = editra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20856254f6a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor : speps <speps at aur dot archlinux dot org>
+# Contributor: Chris Baker <baker.chris.3@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=editra
+pkgver=0.7.20
+pkgrel=1
+pkgdesc="Multi-platform text editor with features that aid in code development"
+arch=('any')
+url="http://$pkgname.org/"
+license=('custom:wxWindows')
+depends=('python2-wxpython3' 'python2-distribute' 'desktop-file-utils')
+source=("${url}uploads/src/${pkgname//e/E}-$pkgver.tar.gz"
+ "$pkgname.desktop")
+md5sums=('a52c6b3d703f98e0390aa7b44f991616'
+ '6082f8d4bf1650af8ce87c6b3d38053b')
+
+build() {
+ cd ${pkgname//e/E}-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd ${pkgname//e/E}-$pkgver
+
+ python2 setup.py install --root="$pkgdir/"
+
+ # desktop and pixmaps
+ install -Dm644 ../${source[1]} "$pkgdir/usr/share/applications/${source[1]}"
+ install -Dm644 pixmaps/$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ # license
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ # python2 fixes
+ sed -i "s|\(^\#\!.*python\).*|\12|" `grep -rl "\#\!.*python" "$pkgdir"`
+}
diff --git a/editra.desktop b/editra.desktop
new file mode 100644
index 000000000000..43249d98efb7
--- /dev/null
+++ b/editra.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=Editra
+GenericName=Integrated Development Environment
+Comment=Multi-platform IDE using wxPython
+Exec=Editra %F
+Icon=editra
+Terminal=false
+Categories=Application;Development;IDE;
+MimeType=text/x-chdr;text/x-csrc;text/x-c++hdr;text/x-c++src;text/x-java;text/x-dsrc;text/x-pascal;text/x-perl;text/x-python;application/x-php;application/x-httpd-php*;application/xml;text/html;text/css;text/x-sql;text/x-diff;
+StartupNotify=true