summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2020-11-15 22:30:43 +0300
committerNeoTheFox2020-11-15 22:30:43 +0300
commit61dd7cf324b75d76f51e86fef0c475c276573c98 (patch)
tree72d80b49492db6e3abb83e0d6ffcd646d2e52534
downloadaur-61dd7cf324b75d76f51e86fef0c475c276573c98.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rwxr-xr-xedmarketconnector.sh4
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f29fdfb54d92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = edmarketconnector
+ pkgdesc = Downloads commodity market and other station data from the game Elite: Dangerous for use with all popular online and offline trading tools
+ pkgver = 4.1.4
+ pkgrel = 1
+ url = https://github.com/EDCD/EDMarketConnector
+ arch = x86_64
+ license = GPL
+ depends = python-certifi
+ depends = python-requests
+ depends = python-watchdog
+ depends = python-semantic-version
+ provides = edmarketconnector
+ conflicts = edmarketconnector
+ source = https://github.com/EDCD/EDMarketConnector/archive/Release/4.1.4.tar.gz
+ source = edmarketconnector.sh
+ sha256sums = 05f1cd79eb0d17dad15394e09fcc2f807e4e2c0242d756fee9e4622f3eb76f0a
+ sha256sums = 7be0528d56edfcb444c4a7ba7a18e85296571e7558906c90fe6520c03206242c
+
+pkgname = edmarketconnector
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d7c2e91f42a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: NeoTheFox <aur at repraptor.33mail.com>
+
+pkgname=edmarketconnector
+pkgver=4.1.4
+pkgrel=1
+pkgdesc='Downloads commodity market and other station data from the game Elite: Dangerous for use with all popular online and offline trading tools'
+arch=('x86_64')
+url='https://github.com/EDCD/EDMarketConnector'
+license=('GPL')
+provides=('edmarketconnector')
+conflicts=('edmarketconnector')
+depends=('python-certifi' 'python-requests' 'python-watchdog' 'python-semantic-version')
+source=("https://github.com/EDCD/EDMarketConnector/archive/Release/${pkgver}.tar.gz"
+ "edmarketconnector.sh")
+sha256sums=('05f1cd79eb0d17dad15394e09fcc2f807e4e2c0242d756fee9e4622f3eb76f0a'
+ '7be0528d56edfcb444c4a7ba7a18e85296571e7558906c90fe6520c03206242c')
+
+#build() {
+# #cd "${srcdir}/${_projectname}-${_gittag}"
+# python setup.py build
+#}
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/edmarketconnector
+ mkdir -p ${pkgdir}/usr/bin/
+ cp ${srcdir}/EDMarketConnector-Release-${pkgver}/* ${pkgdir}/usr/lib/edmarketconnector -r
+ install -m755 edmarketconnector.sh ${pkgdir}/usr/bin/edmarketconnector.sh
+}
+
diff --git a/edmarketconnector.sh b/edmarketconnector.sh
new file mode 100755
index 000000000000..cc38e11c0e08
--- /dev/null
+++ b/edmarketconnector.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/lib/edmarketconnector
+python ./EDMarketConnector.py