summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-04-05 21:27:54 -0400
committerSolomon Choina2020-04-05 21:27:54 -0400
commitb02aece28eaf404709eb106b70d3fc5779f2e538 (patch)
tree1be507d066ae3486bde99824869f8a975399894e
downloadaur-b02aece28eaf404709eb106b70d3fc5779f2e538.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rwxr-xr-xio.github.edo9300.EDOPro.desktop10
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0b1effc1731
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = edopro-bin
+ pkgdesc = Link compatable ygopro client with AI
+ pkgver = 38.0.0
+ pkgrel = 1
+ url = https://github.com/edo9300/edopro
+ arch = x86_64
+ license = GPL2
+ makedepends = patchelf
+ depends = mono
+ depends = libevent
+ depends = libglvnd
+ depends = freetype2
+ options = emptydirs
+ source = local://ProjectIgnis-EDOPro-38.0.0-linux.tar.gz
+ source = io.github.edo9300.EDOPro.desktop
+ sha256sums = f31a12c1f7bd5a9c20d5bdfd657697e8fa16137c93e62f550b409af6e53cbb59
+ sha256sums = 0a9d949f027004c3ef86ba0eaf30e131d4f8c34994ca5fae72cbe08e740d99c7
+
+pkgname = edopro-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9faa923a459
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=edopro-bin
+pkgver=38.0.0
+pkgrel=1
+pkgdesc="Link compatable ygopro client with AI"
+arch=('x86_64')
+url='https://github.com/edo9300/edopro'
+license=('GPL2')
+depends=('mono' 'libevent' 'libglvnd' 'freetype2')
+makedepends=('patchelf')
+source=("local://ProjectIgnis-EDOPro-$pkgver-linux.tar.gz"
+ "io.github.edo9300.EDOPro.desktop")
+sha256sums=('f31a12c1f7bd5a9c20d5bdfd657697e8fa16137c93e62f550b409af6e53cbb59'
+ '0a9d949f027004c3ef86ba0eaf30e131d4f8c34994ca5fae72cbe08e740d99c7')
+options=('emptydirs')
+
+package(){
+ outputDir="$pkgdir/opt/edopro"
+ mkdir -p $outputDir
+ cp -dR ProjectIgnis/* $outputDir
+ find $outputDir -type d -exec chmod 777 {} \;
+ find $outputDir -type f -exec chmod 777 {} \;
+ install -D io.github.edo9300.EDOPro.desktop $pkgdir/usr/share/applications/io.github.edo9300.EDOPro.desktop
+
+ install -Dm755 /dev/stdin "$pkgdir"/usr/bin/EDOPro <<END
+ #!/usr/bin/bash
+ cd /opt/edopro
+ /opt/edopro/EDOPro
+
+END
+
+ # uncomment to get rid of the default decks if wanted
+ #rm $outputDir/deck/*
+}
diff --git a/io.github.edo9300.EDOPro.desktop b/io.github.edo9300.EDOPro.desktop
new file mode 100755
index 000000000000..fe45e84c32df
--- /dev/null
+++ b/io.github.edo9300.EDOPro.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Project Ignis: EDOPro
+Comment=The bleeding-edge automatic duel simulator
+Path=/opt/edopro
+Exec=/usr/bin/EDOPro
+Icon=/opt/edopro/textures/AppIcon.png
+Terminal=false
+Categories=Game;CardGame;