summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Czigány2022-03-18 12:21:57 +0100
committerAndrás Czigány2022-03-18 12:22:30 +0100
commitf0784a5394bd20c7e13ae9ac8d746aa1af1569c1 (patch)
treed28d1be7fd09764bdf8ec546c066a5e8b19f985f
parent3e2f43d61bada29d9da1dcdb8d70424d5fa7cad6 (diff)
downloadaur-f0784a5394bd20c7e13ae9ac8d746aa1af1569c1.tar.gz
eea-dkms v9.0.5.0
Added: ESET Enterprise Inspector support Added: On-demand scan feature in application GUI Added: Ubuntu 20.04 LTS Mate desktop support Added: Scan information available when using odscan utility Added: On-demand scan logs displayed per user Fixed: A potential vulnerability in the on-access scanner - reported internally (CVE-2022-0615) Fixed: Real-time File System Protection blocking Desktop Central Agent Fixed: Settings not reflected properly when using cfg utility Fixed: Problems with product update when using Turkish locale Fixed: Issues with a protection status and expiration when using offline license Fixed: Incorrectly displayed strings in GUI when not supported locale is used Fixed: Meta data not deleted during log optimization process Fixed: Issues with handling non-UTF paths in running scans
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--eea.install65
3 files changed, 40 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b82f8abb1cee..7fd4c3b89194 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eea-dkms
pkgdesc = ESET Endpoint Antivirus Business for Linux (DKMS)
- pkgver = 8.1.7.0
+ pkgver = 9.0.5.0
pkgrel = 1
url = https://www.eset.com/int/business/endpoint-antivirus-linux/
install = eea.install
@@ -14,10 +14,10 @@ pkgbase = eea-dkms
conflicts = esets
conflicts = eea
conflicts = eea7-dkms
- source = https://download.eset.com/com/eset/apps/business/eea/linux/g2/v8/8.1.7.0/eeau.x86_64.bin
+ source = https://download.eset.com/com/eset/apps/business/eea/linux/g2/v9/9.0.5.0/eeau.x86_64.bin
source = dkms.conf
source = dkms_postinst
- sha256sums = 3b933d3df385115d19af7fa5ea63e5d636609213d7ed9b8b71f4c20c874e425a
+ sha256sums = d7682777d1cea6714ea0256bfc272217eb795139227edd60bafdf28d38a10aeb
sha256sums = 53df6d50f98792053da2580df7828a06eef34dd066de684a333dd7569b481f93
sha256sums = 20539f7116bf44defc2df0f244d8c02722b06b97fe6be8a049c4ecafce2d744c
diff --git a/PKGBUILD b/PKGBUILD
index 9e6ef8fc1dc9..ce999f08c878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkgname=eea
pkgname="${_pkgname}-dkms"
-_pkgver_major=8
-pkgver=8.1.7.0
+_pkgver_major=9
+pkgver=9.0.5.0
pkgrel=1
arch=('x86_64')
pkgdesc='ESET Endpoint Antivirus Business for Linux (DKMS)'
@@ -34,7 +34,7 @@ source=("${_bundle_url}/${_bundle_file}"
"dkms_postinst"
)
-sha256sums=('3b933d3df385115d19af7fa5ea63e5d636609213d7ed9b8b71f4c20c874e425a'
+sha256sums=('d7682777d1cea6714ea0256bfc272217eb795139227edd60bafdf28d38a10aeb'
'53df6d50f98792053da2580df7828a06eef34dd066de684a333dd7569b481f93'
'20539f7116bf44defc2df0f244d8c02722b06b97fe6be8a049c4ecafce2d744c')
diff --git a/eea.install b/eea.install
index d187bba07f78..2dbf2be0f199 100644
--- a/eea.install
+++ b/eea.install
@@ -5,10 +5,9 @@ pre_install() {
SYSTEMD_CAT="$(which systemd-cat 2>/dev/null || true)"
print_error() {
errorstr="ESET Endpoint Antivirus error: $1"
+ echo "$errorstr" 1>&2
if [ -n "$SYSTEMD_CAT" ]; then
printf "%s" "$errorstr" | $SYSTEMD_CAT -t "eea" -p err
- else
- echo "$errorstr" 1>&2
fi
}
@@ -45,10 +44,9 @@ pre_upgrade() {
SYSTEMD_CAT="$(which systemd-cat 2>/dev/null || true)"
print_error() {
errorstr="ESET Endpoint Antivirus error: $1"
+ echo "$errorstr" 1>&2
if [ -n "$SYSTEMD_CAT" ]; then
printf "%s" "$errorstr" | $SYSTEMD_CAT -t "eea" -p err
- else
- echo "$errorstr" 1>&2
fi
}
@@ -111,10 +109,9 @@ post_install() {
SYSTEMD_CAT="$(which systemd-cat 2>/dev/null || true)"
print_error() {
errorstr="ESET Endpoint Antivirus error: $1"
+ echo "$errorstr" 1>&2
if [ -n "$SYSTEMD_CAT" ]; then
printf "%s" "$errorstr" | $SYSTEMD_CAT -t "eea" -p err
- else
- echo "$errorstr" 1>&2
fi
}
@@ -132,19 +129,21 @@ post_install() {
}
- if true; then
+ if true || false; then
# first install and upgrade (deb only)
+ # yum: run for "1" (install) and "2" (upgrade)
# check if users have been already created
- if ! grep eset-eea-daemons /etc/group >/dev/null; then
- # create users and groups
- for g in eset-eea-daemons; do
- groupadd -r $g
- done
- for ug in eset-eea-updated:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-confd:eset-eea-daemons eset-eea-scand:eset-eea-daemons; do
+ # create users and groups
+ for g in eset-eea-daemons; do
+ groupadd -r -f $g
+ done
+
+ for ug in eset-eea-confd:eset-eea-daemons eset-eea-updated:eset-eea-daemons eset-eea-scand:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-econnd:eset-eea-daemons; do
+ if ! id "${ug%:*}" > /dev/null 2>&1; then
useradd -d '/opt/eset/eea' -M -N -r -s /sbin/nologin -g "${ug#*:}" "${ug%:*}"
- done
- fi
+ fi
+ done
fi
#################################### Upgrade & Install ####################################
@@ -171,7 +170,9 @@ post_install() {
# extract modules from tar
tar -xf /var/opt/eset/eea/lib/modules_eea.tar -C /var/opt/eset/eea/lib
# compile modules
- if ! /opt/eset/eea/bin/upd --compile-nups ; then
+ /opt/eset/eea/bin/upd --compile-nups
+ upd_return_code=$?
+ if [ $upd_return_code -ne 0 ] && [ $upd_return_code -ne 10 ]; then
print_error 'Module compilation failed.'
fi
@@ -205,10 +206,9 @@ post_upgrade() {
SYSTEMD_CAT="$(which systemd-cat 2>/dev/null || true)"
print_error() {
errorstr="ESET Endpoint Antivirus error: $1"
+ echo "$errorstr" 1>&2
if [ -n "$SYSTEMD_CAT" ]; then
printf "%s" "$errorstr" | $SYSTEMD_CAT -t "eea" -p err
- else
- echo "$errorstr" 1>&2
fi
}
@@ -226,19 +226,21 @@ post_upgrade() {
}
- if true; then
+ if true || false; then
# first install and upgrade (deb only)
+ # yum: run for "1" (install) and "2" (upgrade)
# check if users have been already created
- if ! grep eset-eea-daemons /etc/group >/dev/null; then
- # create users and groups
- for g in eset-eea-daemons; do
- groupadd -r $g
- done
- for ug in eset-eea-updated:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-confd:eset-eea-daemons eset-eea-scand:eset-eea-daemons; do
+ # create users and groups
+ for g in eset-eea-daemons; do
+ groupadd -r -f $g
+ done
+
+ for ug in eset-eea-confd:eset-eea-daemons eset-eea-updated:eset-eea-daemons eset-eea-scand:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-econnd:eset-eea-daemons; do
+ if ! id "${ug%:*}" > /dev/null 2>&1; then
useradd -d '/opt/eset/eea' -M -N -r -s /sbin/nologin -g "${ug#*:}" "${ug%:*}"
- done
- fi
+ fi
+ done
fi
#################################### Upgrade & Install ####################################
@@ -265,7 +267,9 @@ post_upgrade() {
# extract modules from tar
tar -xf /var/opt/eset/eea/lib/modules_eea.tar -C /var/opt/eset/eea/lib
# compile modules
- if ! /opt/eset/eea/bin/upd --compile-nups ; then
+ /opt/eset/eea/bin/upd --compile-nups
+ upd_return_code=$?
+ if [ $upd_return_code -ne 0 ] && [ $upd_return_code -ne 10 ]; then
print_error 'Module compilation failed.'
fi
@@ -299,10 +303,9 @@ pre_remove() {
SYSTEMD_CAT="$(which systemd-cat 2>/dev/null || true)"
print_error() {
errorstr="ESET Endpoint Antivirus error: $1"
+ echo "$errorstr" 1>&2
if [ -n "$SYSTEMD_CAT" ]; then
printf "%s" "$errorstr" | $SYSTEMD_CAT -t "eea" -p err
- else
- echo "$errorstr" 1>&2
fi
}
@@ -351,7 +354,7 @@ post_remove() {
#################################### Uninstall ####################################
# remove users and groups
- for ug in eset-eea-updated:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-confd:eset-eea-daemons eset-eea-scand:eset-eea-daemons; do
+ for ug in eset-eea-confd:eset-eea-daemons eset-eea-updated:eset-eea-daemons eset-eea-scand:eset-eea-daemons eset-eea-logd:eset-eea-daemons eset-eea-licensed:eset-eea-daemons eset-eea-econnd:eset-eea-daemons; do
usr=${ug%:*}
userdel $usr 2>/dev/null || true
done