summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnas Elgarhy2023-04-30 17:13:47 +0200
committerAnas Elgarhy2023-04-30 17:13:47 +0200
commit6f8a4928cbc875582de5205fda3aecdffceb2784 (patch)
tree6813042900a56a460b3881f08fa50c24c8042e36
downloadaur-6f8a4928cbc875582de5205fda3aecdffceb2784.tar.gz
Init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df8c93074b9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = eelu-login
+ pkgdesc = A command-line tool that allows staff and students to log in to the Egyptian E-Learning University Moodle platform quickly and easily through the command-line interface.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/anas-elgarhy/eelu-login
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT OR Apache-2.0
+ makedepends = rust
+ makedepends = cargo
+ provides = eelu-login
+ replaces = eelu-login
+ source = eelu-login-0.2.1.tar.gz::https://static.crates.io/crates/eelu-login/eelu-login-0.2.1.crate
+ sha256sums = 1725e0ee4543afa77df20ce11216a5b551a5d47878caeef85c55a355ad20865f
+
+pkgname = eelu-login
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..177644f2e54d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Anas Elgarhy <anas.elgarhy.dev@gmail.com>
+pkgname=eelu-login
+pkgver=0.2.1
+pkgrel=1
+epoch=
+pkgdesc="A command-line tool that allows staff and students to log in to the Egyptian E-Learning University Moodle platform quickly and easily through the command-line interface."
+makedepends=('rust' 'cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/anas-elgarhy/eelu-login"
+license=('MIT OR Apache-2.0')
+provides=(eelu-login)
+replaces=(eelu-login)
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+noextract=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}
+sha256sums=('1725e0ee4543afa77df20ce11216a5b551a5d47878caeef85c55a355ad20865f')