summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnas Elgarhy2023-04-30 18:19:41 +0200
committerAnas Elgarhy2023-04-30 18:19:41 +0200
commit2ca0410334b07e4b6fc890629e1baf402bc9d554 (patch)
treefbbc90c5404bd7e9b9b9e919188e0118cd2bfa23
downloadaur-2ca0410334b07e4b6fc890629e1baf402bc9d554.tar.gz
fix
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8b52402a89f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = eelu-login-git
+ pkgdesc = A command-line tool that allows staff and students to log in to the Egyptian E-Learning University Moodle platform quickly and easily through the command-line interface.
+ pkgver = v0.2.0.r19.gcd8556b
+ pkgrel = 1
+ url = https://github.com/anas-elgarhy/eelu-login
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT OR Apache-2.0
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = eelu-login
+ replaces = eelu-login
+ source = eelu-login-git::git+https://github.com/anas-elgarhy/eelu-login#branch=master
+ sha256sums = SKIP
+
+pkgname = eelu-login-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeae41a8fdba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Anas Elgarhy <anas.elgarhy.dev@gmail.com>
+pkgname=eelu-login-git
+pkgver=v0.2.0.r19.gcd8556b
+pkgrel=1
+epoch=
+pkgdesc="A command-line tool that allows staff and students to log in to the Egyptian E-Learning University Moodle platform quickly and easily through the command-line interface."
+makedepends=('rust' 'cargo' 'git')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/anas-elgarhy/eelu-login"
+license=('MIT OR Apache-2.0')
+provides=(eelu-login)
+replaces=(eelu-login)
+install=
+changelog=
+source=("$pkgname::git+$url#branch=master")
+noextract=()
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}
+sha256sums=('SKIP')