summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiao Junxuan2024-04-01 10:20:01 +0800
committerLiao Junxuan2024-04-01 10:20:01 +0800
commitf09e73939306402d4e5d0ae4438218e49c0dc9e4 (patch)
treea8508c18f8f4dba6850bd7d1c635624fcc759251
parent7703e76aea6dd54bc4fdce69db7e59f7e9e81867 (diff)
downloadaur-f09e73939306402d4e5d0ae4438218e49c0dc9e4.tar.gz
don't use CFLAGS
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a0c0dff966c..4e23b3d7295d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,10 @@ build() {
mkdir -p build
cd build
# shellcheck disable=SC2086
- gnatmake $CFLAGS -gnat2012 ../eepers.adb -largs "$LDFLAGS" -lraylib -lm -pthread
+ FLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 \
+ -fstack-clash-protection -fcf-protection"
+ gnatmake $FLAGS -gnat2012 ../eepers.adb -largs "$LDFLAGS" -lraylib -lm -pthread
}
package() {