summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:05:51 -0600
committernot_anonymous2015-07-05 18:05:51 -0600
commit2c1a72d5b4891a2a00f0a6f6c7d8f7587f06b2a3 (patch)
treeadd645b53226cd5f5ca70d72046aae404d667381
downloadaur-2c1a72d5b4891a2a00f0a6f6c7d8f7587f06b2a3.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
-rw-r--r--eepkeyer.desktop16
-rw-r--r--eepkeyer.install11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ffdbad45780
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = eepkeyer
+ pkgdesc = Ham Radio Contest CW Keyer
+ pkgver = 1.7
+ pkgrel = 1
+ url = http://hamsoftware.org/old_index.html
+ install = eepkeyer.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ optdepends = xlog: logbook
+ optdepends = hamlib: rig interfacing
+ optdepends = cwdaemon: transmitting cw
+ optdepends = winkeydeamon: usb cw xmit
+ optdepends = cabanalyst: cabrillo generation
+ source = http://www.hamsoftware.org/eepkeyer_v1.7.tgz
+ source = eepkeyer.desktop
+ md5sums = 49a908a2380ecd30c0f1fa05d1e5db64
+ md5sums = 0a9b720f7c8dba3b691c8c6c14e199ff
+ sha256sums = 5702726a8a68896820390033c4265c00730690b42dbdd05f1bf55ef4c3bb12b6
+ sha256sums = 2a57de4da7f86c1d158f3fe331d7e0bfe0949f914207af5b3d50613eec44f607
+
+pkgname = eepkeyer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c939b43bcb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=eepkeyer
+pkgver=1.7
+pkgrel=1
+pkgdesc="Ham Radio Contest CW Keyer"
+arch=('i686' 'x86_64')
+url="http://hamsoftware.org/old_index.html"
+license=('GPL3')
+depends=('qt4')
+optdepends=('xlog: logbook'
+ 'hamlib: rig interfacing'
+ 'cwdaemon: transmitting cw'
+ 'winkeydeamon: usb cw xmit'
+ 'cabanalyst: cabrillo generation')
+install=$pkgname.install
+source=(http://www.hamsoftware.org/${pkgname}_v$pkgver.tgz
+ $pkgname.desktop)
+
+build() {
+ cd "$srcdir/${pkgname}_v$pkgver/"
+
+ /usr/lib/qt4/bin/qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}_v$pkgver/"
+
+ make INSTALL_ROOT="$pkgdir/" install
+
+ install -Dm644 README.txt $pkgdir/usr/share/$pkgname/docs/README.txt
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 images/*.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+md5sums=('49a908a2380ecd30c0f1fa05d1e5db64'
+ '0a9b720f7c8dba3b691c8c6c14e199ff')
+sha256sums=('5702726a8a68896820390033c4265c00730690b42dbdd05f1bf55ef4c3bb12b6'
+ '2a57de4da7f86c1d158f3fe331d7e0bfe0949f914207af5b3d50613eec44f607')
diff --git a/eepkeyer.desktop b/eepkeyer.desktop
new file mode 100644
index 000000000000..10145f89cf64
--- /dev/null
+++ b/eepkeyer.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=eepKeyer
+Name[en_US]=eepKeyer
+Comment=CW contest keyer
+Comment[en_US]=CW contest keyer
+Encoding=UTF-8
+Exec=eepkeyer
+Icon=eepkeyer.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/eepkeyer.install b/eepkeyer.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/eepkeyer.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}