summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2017-12-15 22:38:03 +0100
committerSanpi2017-12-15 22:42:03 +0100
commit272568097859ece33fa6b6baa9729b8ec7c4508f (patch)
tree6ba3a5042b42c962325251863f738739878dcbe2
downloadaur-272568097859ece33fa6b6baa9729b8ec7c4508f.tar.gz
v1.0.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2665e9ca7348
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = effitask
+ pkgdesc = Graphical task manager, based on the todo.txt format
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/sanpii/effitask
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = gtk3
+ source = https://github.com/sanpii/effitask/archive/1.0.1.tar.gz
+ sha256sums = 37199050cf90bead04b11c63c3a34dcc6479d81ba12cda3b1a711068532ab6f7
+
+pkgname = effitask
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39f18da64cb8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/*.pkg.tar.xz
+/*.tar.gz
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce8d5f914835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=effitask
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Graphical task manager, based on the todo.txt format'
+url="https://github.com/sanpii/$pkgname"
+arch=('x86_64')
+license=('MIT')
+depends=('gtk3')
+makedepends=('cargo')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('37199050cf90bead04b11c63c3a34dcc6479d81ba12cda3b1a711068532ab6f7')
+
+build()
+{
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+
+ make install PREFIX="$pkgdir"
+}