summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-09-07 01:31:57 +0530
committerKeshav Amburay2013-09-07 01:31:57 +0530
commitdf09c01646f43352125bf7a2a043e9389b256158 (patch)
tree1b859a20bde130a52817b96044a6d0bcaf9195de
parentb0486f252b2839f0dd6bf6a842ded25513249ded (diff)
downloadaur-df09c01646f43352125bf7a2a043e9389b256158.tar.gz
Fix patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--efibootmgr-remove-loader-path-chars-limit.patch10
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4638a96052ad..93e52c0a92d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,7 @@ pkgbase = efibootmgr-pjones-git
source = efibootmgr-pjones::git+https://github.com/vathpela/efibootmgr.git#branch=libefivars
source = efibootmgr-remove-loader-path-chars-limit.patch
sha1sums = SKIP
- sha1sums = f52fe466a80e9f06d6f8301966a080d2d9836a73
+ sha1sums = 57cb0e01d9c102491fc1758766f530813cad97d2
pkgname = efibootmgr-pjones-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ee3b3503720..64c43ff95274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}"
'efibootmgr-remove-loader-path-chars-limit.patch')
sha1sums=('SKIP'
- 'f52fe466a80e9f06d6f8301966a080d2d9836a73')
+ '57cb0e01d9c102491fc1758766f530813cad97d2')
pkgver() {
cd "${srcdir}/${_gitname}/"
diff --git a/efibootmgr-remove-loader-path-chars-limit.patch b/efibootmgr-remove-loader-path-chars-limit.patch
index 9d2987d7d5df..a8d1067fc058 100644
--- a/efibootmgr-remove-loader-path-chars-limit.patch
+++ b/efibootmgr-remove-loader-path-chars-limit.patch
@@ -1,5 +1,5 @@
diff --git a/src/lib/efi.c b/src/lib/efi.c
-index cc8a73a..08a98b1 100644
+index cc8a73a..c34d29f 100644
--- a/src/lib/efi.c
+++ b/src/lib/efi.c
@@ -476,7 +476,7 @@ make_disk_load_option(char *disk, uint8_t *buf, size_t size)
@@ -11,15 +11,17 @@ index cc8a73a..08a98b1 100644
size_t needed = 0;
off_t buf_offset = 0;
-@@ -519,10 +519,14 @@ make_disk_load_option(char *disk, uint8_t *buf, size_t size)
+@@ -519,10 +519,15 @@ make_disk_load_option(char *disk, uint8_t *buf, size_t size)
return needed;
buf_offset += needed;
-+ os_loader_path = calloc(strlen(opts.loader)+1, sizeof(*os_loader_path));
++ needed = (strlen(opts.loader) + 1) * sizeof (*os_loader_path);
++ os_loader_path = malloc(needed);
+ if (!os_loader_path)
+ return -1;
efichar_from_char(os_loader_path, tilt_slashes(opts.loader),
- sizeof(os_loader_path));
+- sizeof(os_loader_path));
++ needed);
needed = make_file_path_device_path(os_loader_path, buf + buf_offset,
size == 0 ? 0 : size - buf_offset);
+ free(os_loader_path);