summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuma7C92016-12-11 19:08:49 +0100
committerJuma7C92016-12-11 19:08:49 +0100
commit1a62f6860fede6ce284b618e2fda3360ad11db32 (patch)
tree1825b1dbba58fb56fdff1bf1dc9e9fe93e308670
downloadaur-1a62f6860fede6ce284b618e2fda3360ad11db32.tar.gz
First release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e23a00723955
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = efiedit
+ pkgdesc = Efibootmgr wrapper to view and edit boot entries
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Juma7C9/Efiedit
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = efibootmgr
+ options = strip
+ source = https://github.com/Juma7C9/Efiedit/releases/download/v1.0/efiedit-1.0.tar.xz
+ sha256sums = 35a1393f9bf43bdecb7b98ccdcd23e202cee8bf04190f773f53138159af51bd7
+
+pkgname = efiedit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e74636536c52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Juri Vitali <juri@dividebyzero.it>
+
+pkgname=efiedit
+pkgver=1.0
+pkgrel=1
+pkgdesc="Efibootmgr wrapper to view and edit boot entries"
+arch=('i686' 'x86_64')
+url="https://github.com/Juma7C9/Efiedit"
+license=('GPL3')
+depends=('efibootmgr')
+options=('strip')
+source=("https://github.com/Juma7C9/Efiedit/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('35a1393f9bf43bdecb7b98ccdcd23e202cee8bf04190f773f53138159af51bd7')
+
+
+build() {
+ cd "$srcdir"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 0755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 0644 "example.conf" "$pkgdir/usr/lib/$pkgname/$pkgname.conf.example"
+ install -Dm 0644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}