summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-07-08 23:48:31 +0530
committerKeshav Amburay2013-07-08 23:48:31 +0530
commit8f85b82c2aec629b8190888fa635c8467549c60a (patch)
tree91060adb562d5a9f575b18cafa336f0d120189d7
parent6e32173e5a024133136e58a098dd59d32384ce32 (diff)
downloadaur-8f85b82c2aec629b8190888fa635c8467549c60a.tar.gz
Fix pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b36acca946fa..6b4cc1afa73d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = efitools-git
pkgdesc = Tools to Create and Setup own UEFI Secure Boot Certificates, Keys and Signed Binaries - GIT Version
- pkgver = v1.4.1.6.gf5d338c
+ pkgver = 1.4.1.6.gf5d338c
pkgrel = 1
url = http://blog.hansenpartnership.com/efitools-1-4-with-linux-key-manipulation-utilities-released/
install = efitools.install
diff --git a/PKGBUILD b/PKGBUILD
index a21848ff13b4..b4e6d6342790 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _gitbranch="master"
_pkgname="efitools"
pkgname="${_pkgname}-git"
-pkgver=v1.4.1.6.gf5d338c
+pkgver=1.4.1.6.gf5d338c
pkgrel=1
pkgdesc="Tools to Create and Setup own UEFI Secure Boot Certificates, Keys and Signed Binaries - GIT Version"
url="http://blog.hansenpartnership.com/efitools-1-4-with-linux-key-manipulation-utilities-released/"
@@ -30,7 +30,7 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}/"
- echo "$(git describe --tags)" | sed 's|-|.|g'
+ echo "$(git describe --tags)" | sed -e 's|^v||g' -e 's|-|.|g'
}
build() {
@@ -59,4 +59,7 @@ package() {
make DESTDIR="${pkgdir}/" install
echo
+ ## Do not install LockDown.efi
+ rm -f "${pkgdir}/usr/share/efitools/efi/LockDown.efi" || true
+
}