summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-04-29 16:41:25 +0530
committerKeshav Amburay2013-04-29 16:41:25 +0530
commit0753e99c8094c75594b456c82585acb878b6df3c (patch)
tree8269e0cbb81765acee4233f3cf3b580adff2c4d4
parent072d578c38ec94f2ef5edf56f53ffc17d2d6949b (diff)
downloadaur-0753e99c8094c75594b456c82585acb878b6df3c.tar.gz
M
-rw-r--r--PKGBUILD36
1 files changed, 6 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 411a8dd31e4d..3e3956286c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,9 @@
# Maintainer : Keshav Padram <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+_gitroot="git://github.com/vathpela/libefivar.git"
+_gitname="libefivar"
+_gitbranch="master"
+
_pkgname="libefivar"
pkgname="${_pkgname}-git"
@@ -14,40 +18,12 @@ license=('GPL2')
depends=('glibc')
options=('!strip' '!emptydirs' 'zipman' '!libtool' 'docs')
-_gitroot="git://github.com/vathpela/libefivar.git"
-_gitname="${_pkgname}"
-_gitbranch="master"
-
source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}")
sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- git describe --always | sed 's|-|.|g'
-}
-
-_update_git() {
-
- cd "${srcdir}/"
-
- msg "Connecting to GIT server...."
-
- if [[ -d "${srcdir}/${_gitname}/" ]]; then
- cd "${srcdir}/${_gitname}/"
- git reset --hard
- git fetch
- git checkout "${_gitbranch}"
- git merge "remotes/origin/${_gitbranch}"
- msg "The local GIT repo has been updated."
- else
- git clone "${_gitroot}" "${_gitname}"
- cd "${srcdir}/${_gitname}/"
- git checkout "${_gitbranch}"
- msg "GIT checkout done or server timeout"
- fi
-
- echo
-
+ cd "${srcdir}/${_gitname}/"
+ git describe --always | sed 's|-|.|g'
}
build() {