summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author404DeadLink2020-11-23 13:30:51 +0100
committer404DeadLink2020-11-23 13:32:29 +0100
commit807700dab2ef990265b2df838da21cef94a3a551 (patch)
tree707424755647f1e5e9e547712248e3b1c3645cfe
downloadaur-807700dab2ef990265b2df838da21cef94a3a551.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6408caea945
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = efivar-static
+ pkgdesc = static libraries and executable to work with EFI variables
+ pkgver = 37
+ pkgrel = 4
+ url = https://github.com/rhboot/efivar
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = glibc
+ provides = libefiboot.a
+ provides = libefivar.a
+ source = git+https://github.com/rhinstaller/efivar.git#tag=37
+ sha512sums = SKIP
+
+pkgname = efivar-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e180466601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: 404DeadLink <>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+
+pkgname=efivar-static
+pkgdesc="static libraries and executable to work with EFI variables"
+pkgver=37
+pkgrel=4
+arch=('x86_64')
+url="https://github.com/rhboot/efivar"
+license=('LGPL2.1')
+makedepends=('git')
+depends=('glibc')
+provides=('libefiboot.a' 'libefivar.a')
+source=("git+https://github.com/rhinstaller/efivar.git#tag=${pkgver}")
+sha512sums=('SKIP')
+
+prepare() {
+ mv -v "${pkgname%-static}" "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+ # -Werror, not even once
+ sed -e 's/-Werror//g' -i gcc.specs
+ # remove insecure rpath in efivar-tester
+ sed 's|-rpath,$(TOPDIR)/src|-rpath,$(libdir)|g' -i src/test/Makefile
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make libdir="/usr/lib/" \
+ bindir="/usr/bin/" \
+ mandir="/usr/share/man/" \
+ includedir="/usr/include/"\
+ static
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/src"
+ install -dm 755 "${pkgdir}/usr/lib"
+ install -dm 755 "${pkgdir}/usr/bin"
+ install -m 755 "${provides}" "${pkgdir}/usr/lib"
+ install -m 755 "efivar-static" "${pkgdir}/usr/bin"
+}