summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman)2017-07-13 10:35:38 +0900
committerCarsten Haitzler (Rasterman)2017-09-03 10:07:35 +0900
commit7acb6970b00af350ab4b751a9303266f607e4c5e (patch)
treedcfec3a278fe7f17e381a03f4ee18d49a336efe3
parent9142443ef76fdd287b0f20fe81546b48245c3b14 (diff)
downloadaur-7acb6970b00af350ab4b751a9303266f607e4c5e.tar.gz
update and improve efl pkgbuild
i just did some ... improvements. 1. updated pkgver (well it auto-updated on build) 2. updated license list to be more accurate 3. fixed depends (gtk3 is not a dependency - never has been. it's glib that is (and that can be --disabled to remove glib loop integration support) 4. added shared-mime-info and ttf-font from the enlightenment-git pkg as these are actually efl dependencies, not enlightenment ones. 5. added scim and libibus because scim is the default inpute method supported and i enabled ibus so people have options other than scim (ibus works fine) 6. i switched from glx to egl+gles ... to enable full wayland support and accel (also enabled). note on nvidia + x11 egl+gles has performance issues which need to be resolved upstream somehow (a workaround perhaps?) this should allow people to do various things in addition to working on x11: 1.run efl apps in the "framebuffer" with full gl acceleration too (gl_drm support). terminology works just fine this way for example. 2. use wayland support in enlightenment.
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5111edd0437..12899b9325f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,18 @@
_pkgname=efl
pkgname=$_pkgname-git
-pkgver=1.18.0beta1.49353.g4352747
+pkgver=1.20.99.55194.gc51f35d42a
pkgrel=1
pkgdesc="Enlightenment Foundation Libraries - Development version"
arch=('i686' 'x86_64')
url="http://www.enlightenment.org"
-license=('BSD' 'LGPL2.1' 'GPL2' 'custom')
-depends=('avahi' 'bullet' 'curl' 'fontconfig' 'fribidi' 'gst-plugins-base-libs' 'wayland-protocols' 'luajit' 'libexif'
- 'libgl' 'libinput' 'libpulse' 'libspectre' 'libraw' 'librsvg' 'libwebp' 'libxcomposite'
- 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxp' 'libxrandr' 'libxss' 'libunwind'
- 'mesa' 'openjpeg' 'poppler' 'wayland')
+license=('BSD' 'LGPL2.1' 'GPL2' 'MIT' 'custom')
+depends=('avahi' 'bullet' 'curl' 'fontconfig' 'fribidi'
+ 'gst-plugins-base-libs' 'luajit' 'libexif' 'libgl' 'libinput'
+ 'libpulse' 'libspectre' 'libraw' 'librsvg' 'libwebp' 'libxcomposite'
+ 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxp' 'libxrandr'
+ 'libxss' 'libunwind' 'mesa' 'openjpeg2' 'poppler' 'wayland'
+ 'shared-mime-info' 'ttf-font' 'scim' 'libibus' 'glib2')
makedepends=('git' 'python2')
optdepends=('geoclue: For elocation'
'gst-plugins-base: Video and thumbnail codecs'
@@ -48,12 +50,16 @@ build() {
./autogen.sh \
--prefix=/usr \
--with-tests=none \
- --with-opengl=full \
- --disable-egl \
+ --with-opengl=es \
+ --enable-egl \
--enable-wayland \
--enable-drm \
+ --enable-gl-drm \
+ --enable-drm-hw-accel \
--enable-elput \
+ --enable-libinput \
--enable-fb \
+ --enable-ibus \
--disable-tslib \
--enable-image-loader-webp \
--enable-systemd \