summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-03-17 12:47:32 -0500
committerDoug Newgard2013-03-17 12:47:32 -0500
commitb53a0027f01ec668f4043ad15b5c35d8c7c5c334 (patch)
treead3bf8d70f932eece6cf7f162029fc6ed5b7350b
parent38df7c6f650bd0a616aad29493b08ea58b2c6d62 (diff)
downloadaur-b53a0027f01ec668f4043ad15b5c35d8c7c5c334.tar.gz
Makepkg 4.1 update
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD62
3 files changed, 41 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f851c871211..3a518c8c156f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = efl-git
pkgdesc = Enlightenment Foundation Libraries - Development version (Ecore, EDBus, Edje, Eet, Eeze, Efreet, Eina, Eio, Embryo, Emotion, Eo, Ephysics, Ethumb, & Evas)
- pkgver = 20130312
+ pkgver = 1.7.99.x
pkgrel = 1
url = http://www.enlightenment.org
install = efl.install
@@ -40,62 +40,51 @@ pkgbase = efl-git
optdepends = gstreamer0.10-bad-plugins: Access more types of video in Emotion
optdepends = gstreamer0.10-ugly-plugins: Access more types of video in Emotion
optdepends = gstreamer0.10-ffmpeg: Access video with ffmpeg in Emotion
- provides = ecore
+ provides = ecore=$pkgver
provides = ecore-svn
provides = edbus
provides = edbus-svn
- provides = edje
+ provides = edje=$pkgver
provides = edje-svn
- provides = eet
+ provides = eet=$pkgver
provides = eet-svn
- provides = eeze
+ provides = eeze=$pkgver
provides = eeze-svn
- provides = efreet
+ provides = efreet=$pkgver
provides = efreet-svn
- provides = eina
+ provides = eina=$pkgver
provides = eina-svn
- provides = eio
+ provides = eio=$pkgver
provides = eio-svn
- provides = embryo
+ provides = embryo=$pkgver
provides = embryo-svn
- provides = emotion
+ provides = emotion=$pkgver
provides = emotion-svn
provides = ephysics
provides = ephysics-svn
- provides = ethumb
+ provides = ethumb=$pkgver
provides = ethumb-svn
- provides = evas
+ provides = evas=$pkgver
provides = evas-svn
provides = efl-svn
conflicts = ecore
- conflicts = ecore-svn
conflicts = edbus
- conflicts = edbus-svn
conflicts = edje
- conflicts = edje-svn
conflicts = eet
- conflicts = eet-svn
conflicts = eeze
- conflicts = eeze-svn
conflicts = efreet
- conflicts = efreet-svn
conflicts = eina
- conflicts = eina-svn
conflicts = eio
- conflicts = eio-svn
conflicts = embryo
- conflicts = embryo-svn
conflicts = emotion
- conflicts = emotion-svn
conflicts = ephysics
- conflicts = ephysics-svn
conflicts = ethumb
- conflicts = ethumb-svn
conflicts = evas
- conflicts = evas-svn
conflicts = efl-svn
options = !libtool
- options = !strip
+ options = debug
+ source = git://git.enlightenment.org/core/efl.git
+ md5sums = SKIP
pkgname = efl-git
diff --git a/.gitignore b/.gitignore
index e4fa42cf9be4..cfd5f1c65302 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
src/
pkg/
*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 44cbd0f9b835..3d2faddc9a0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: Ronald van Haren <ronald.archlinux.org>
pkgname=efl-git
-pkgver=20130312
+_pkgname=efl
+pkgver=1.7.99.x
pkgrel=1
pkgdesc="Enlightenment Foundation Libraries - Development version (Ecore, EDBus, Edje, Eet, Eeze, Efreet, Eina, Eio, Embryo, Emotion, Eo, Ephysics, Ethumb, & Evas)"
arch=('i686' 'x86_64')
@@ -22,42 +23,31 @@ optdepends=('python2: compare Eina benchmarks'
'gstreamer0.10-ugly-plugins: Access more types of video in Emotion'
'gstreamer0.10-ffmpeg: Access video with ffmpeg in Emotion'
)
-conflicts=('ecore' 'ecore-svn' 'edbus' 'edbus-svn' 'edje' 'edje-svn'
- 'eet' 'eet-svn' 'eeze' 'eeze-svn' 'efreet' 'efreet-svn'
- 'eina' 'eina-svn' 'eio' 'eio-svn' 'embryo' 'embryo-svn'
- 'emotion' 'emotion-svn' 'ephysics' 'ephysics-svn'
- 'ethumb' 'ethumb-svn' 'evas' 'evas-svn' 'efl-svn')
-provides=('ecore' 'ecore-svn' 'edbus' 'edbus-svn' 'edje' 'edje-svn'
- 'eet' 'eet-svn' 'eeze' 'eeze-svn' 'efreet' 'efreet-svn'
- 'eina' 'eina-svn' 'eio' 'eio-svn' 'embryo' 'embryo-svn'
- 'emotion' 'emotion-svn' 'ephysics' 'ephysics-svn'
- 'ethumb' 'ethumb-svn' 'evas' 'evas-svn' 'efl-svn')
+provides=('ecore=$pkgver' 'ecore-svn' 'edbus' 'edbus-svn' 'edje=$pkgver' 'edje-svn'
+ 'eet=$pkgver' 'eet-svn' 'eeze=$pkgver' 'eeze-svn' 'efreet=$pkgver' 'efreet-svn'
+ 'eina=$pkgver' 'eina-svn' 'eio=$pkgver' 'eio-svn' 'embryo=$pkgver' 'embryo-svn'
+ 'emotion=$pkgver' 'emotion-svn' 'ephysics' 'ephysics-svn'
+ 'ethumb=$pkgver' 'ethumb-svn' 'evas=$pkgver' 'evas-svn' 'efl-svn')
+conflicts=('ecore' 'edbus' 'edje' 'eet' 'eeze' 'efreet' 'eina' 'eio'
+ 'embryo' 'emotion' 'ephysics' 'ethumb' 'evas' 'efl-svn')
+options=('!libtool' 'debug')
install=efl.install
-options=('!libtool' '!strip')
-
-_gitroot="git://git.enlightenment.org/core/efl.git"
-_gitname="efl"
+source=("git://git.enlightenment.org/core/$_pkgname.git")
+md5sums=('SKIP')
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
+pkgver() {
+ cd "$srcdir/$_pkgname"
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
+ echo $(grep -m 1 EFL_VERSION configure.ac | grep -o "[[:digit:]]*" | tr '\n' '.')$(git rev-list --count HEAD)
+}
+prepare() {
# set python scripts to run with python2
- sed -i 's/env python/python2/g' "$srcdir/$_gitname-build/src/scripts/eina/eina-bench-cmp"
+ sed -i 's/env python/python2/g' "$srcdir/$_pkgname/src/scripts/eina/eina-bench-cmp"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
./autogen.sh \
--prefix=/usr \
@@ -65,8 +55,8 @@ build() {
--with-opengl=full \
--with-tests=none \
--enable-systemd \
- --enable-wayland \
--enable-harfbuzz \
+ --enable-wayland \
--enable-fb \
--disable-tslib
@@ -74,7 +64,8 @@ build() {
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_pkgname"
+
make -j1 DESTDIR="$pkgdir" install
# install license files
@@ -82,7 +73,4 @@ package() {
install -Dm644 AUTHORS "$pkgdir/usr/share/licenses/$pkgname/AUTHORS"
install -Dm644 licenses/COPYING.BSD "$pkgdir/usr/share/licenses/$pkgname/COPYING.BSD"
install -Dm644 licenses/COPYING.SMALL "$pkgdir/usr/share/licenses/$pkgname/COPYING.SMALL"
-
-# remove build directory
- rm -r "$srcdir/$_gitname-build"
}