summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-08-22 12:33:54 -0500
committerDoug Newgard2014-08-22 12:33:54 -0500
commitc1190077e88ec32a2a08c6a5b1f889e3ff60fe8e (patch)
treec62754d5c9f11f98554df97868e17c5bfb43c17f
parentedd512464d03daa20630a7fd6f1fce49bfb7013e (diff)
downloadaur-c1190077e88ec32a2a08c6a5b1f889e3ff60fe8e.tar.gz
Use external lz4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c83236b1ce9..1eb9e1fbdb95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = efl-git
pkgdesc = Enlightenment Foundation Libraries - Development version
- pkgver = 1.10.99.25802.b8ca758
+ pkgver = 1.11.99.27394.974e3af
pkgrel = 1
url = http://www.enlightenment.org
install = efl.install
@@ -30,6 +30,7 @@ pkgbase = efl-git
depends = libxp
depends = libxrandr
depends = libxss
+ depends = lz4
depends = shared-mime-info
depends = wayland
depends = openjpeg
@@ -40,7 +41,7 @@ pkgbase = efl-git
optdepends = gst-plugins-ugly: Access more types of video in Emotion
optdepends = gst-libav: Access video with ffmpeg/libav in Emotion
optdepends = evas_generic_loaders-git: More video/graphic/icon loaders for Evas
- provides = efl=1.10.99.25802.b8ca758
+ provides = efl=1.11.99.27394.974e3af
conflicts = efl
options = debug
source = git://git.enlightenment.org/core/efl.git
diff --git a/PKGBUILD b/PKGBUILD
index 80d6992a7321..39d68fbc43a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=efl
pkgname=$_pkgname-git
-pkgver=1.10.99.25802.b8ca758
+pkgver=1.11.99.27394.974e3af
pkgrel=1
pkgdesc="Enlightenment Foundation Libraries - Development version"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ url="http://www.enlightenment.org"
license=('BSD' 'LGPL2.1' 'GPL2' 'custom')
depends=('avahi' 'bullet' 'curl' 'fontconfig' 'fribidi' 'gst-plugins-base-libs' 'luajit' 'libexif'
'libgl' 'libpulse' 'libwebp' 'libxcomposite' 'libxcursor' 'libxinerama' 'libxkbcommon'
- 'libxp' 'libxrandr' 'libxss' 'shared-mime-info' 'wayland')
+ 'libxp' 'libxrandr' 'libxss' 'lz4' 'shared-mime-info' 'wayland')
[[ ! $(pacman -T "openjpeg") ]] && depends+=('openjpeg') #jpeg2k loader is autodetected at build time
makedepends=('git' 'python2')
optdepends=('python2: compare Eina benchmarks'
@@ -56,7 +56,8 @@ build() {
--enable-systemd \
--enable-harfbuzz \
--enable-xinput22 \
- --enable-multisense
+ --enable-multisense \
+ --enable-liblz4
make
}