summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-07-25 12:27:29 +0200
committerÉtienne Deparis2015-07-25 12:27:29 +0200
commitd11c5a074484482ccecb8762b4e8019c82c876d3 (patch)
tree75c607dba6c79bbf123df1597e28afc02dc9e555
parent500eb6bb67fc9a2d566a073cf7ccc9a32bc9c8ef (diff)
downloadaur-d11c5a074484482ccecb8762b4e8019c82c876d3.tar.gz
Change package source to pypi and add correct license information in filesystem
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88099baa73b4..2dcbacd09aa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by makepkg 4.2.1
-# Fri Jul 24 09:09:25 UTC 2015
+# Sat Jul 25 10:23:23 UTC 2015
pkgbase = eg
pkgdesc = Useful examples at the command line
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/srsudar/eg
arch = any
license = MIT
makedepends = python-setuptools
depends = python
options = !emptydirs
- source = eg-0.1.1.tar.gz::https://github.com/srsudar/eg/archive/v0.1.1.tar.gz
- sha256sums = 83bc25bfcbe5a9bfd136587edf4b666feeee4e22c0e48d4a27e8bcfcacd5b63e
+ source = https://pypi.python.org/packages/source/e/eg/eg-0.1.1.tar.gz
+ source = https://raw.githubusercontent.com/srsudar/eg/v0.1.1/LICENSE.txt
+ md5sums = 6e60ff29baa96902037dfbfd32b79f3d
+ md5sums = 0ef25a9a8b81a77d44804af83c7d4717
pkgname = eg
diff --git a/PKGBUILD b/PKGBUILD
index a9fde7f315fc..d93bfe1394c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,24 @@
pkgname=eg
pkgver=0.1.1
-pkgrel=1
+pkgrel=3
pkgdesc="Useful examples at the command line"
license=("MIT")
url="https://github.com/srsudar/eg"
depends=('python')
makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/srsudar/eg/archive/v${pkgver}.tar.gz")
-sha256sums=('83bc25bfcbe5a9bfd136587edf4b666feeee4e22c0e48d4a27e8bcfcacd5b63e')
+# source=("${pkgname}-${pkgver}.tar.gz::https://github.com/srsudar/eg/archive/v${pkgver}.tar.gz")
+# sha256sums=('83bc25bfcbe5a9bfd136587edf4b666feeee4e22c0e48d4a27e8bcfcacd5b63e')
+source=("https://pypi.python.org/packages/source/e/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/srsudar/${pkgname}/v${pkgver}/LICENSE.txt")
+md5sums=('6e60ff29baa96902037dfbfd32b79f3d'
+ '0ef25a9a8b81a77d44804af83c7d4717')
arch=('any')
options=(!emptydirs)
package() {
- cd $srcdir/$pkgname-$pkgver
+ mv LICENSE.txt ${srcdir}/LICENSE
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root=$pkgdir
+ install -D -m644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-