summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-04-27 12:10:30 +0200
committerÉtienne Deparis2015-04-27 12:10:30 +0200
commitdee29ee8779919e0280345add6481de652273558 (patch)
treea2ad505b5b41552585669e1c8d6b4d333d8435eb
downloadaur-dee29ee8779919e0280345add6481de652273558.tar.gz
New pkgbuild version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54424d82b1a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Mon Apr 27 10:02:22 UTC 2015
+pkgbase = eg
+ pkgdesc = Useful examples at the command line
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/srsudar/eg
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = eg-0.0.3.tar.gz::https://github.com/srsudar/eg/archive/v0.0.3.tar.gz
+ sha256sums = c257e334f2a2e494f9b9791b92c1d3f7b00da3e2e7ec47f02d720342b466f968
+
+pkgname = eg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a0a534ea410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Étienne Deparis <etienne [at] depar.is>
+
+pkgname=eg
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Useful examples at the command line"
+license=("MIT")
+url="https://github.com/srsudar/eg"
+makedepends=('python2-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/srsudar/eg/archive/v${pkgver}.tar.gz")
+arch=('any')
+options=(!emptydirs)
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ find . -type f -exec sed -i \
+ -e'1s|^#!/usr/bin/env python$|#!/usr/bin/env python2|' \
+ -e '1s|^#!/usr/bin/python$|#!/usr/bin/env python2|' \
+ "{}" \;
+
+ python2 setup.py install --root=$pkgdir
+}
+
+sha256sums=('c257e334f2a2e494f9b9791b92c1d3f7b00da3e2e7ec47f02d720342b466f968')