summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-05 12:18:41 +0900
committerhayao2020-03-05 12:18:41 +0900
commit39af8abf39a51f748bd52f7c386c76717c723e7c (patch)
treee2cc32c3f652cd3d1f2039b77a0c16cf089e479e
downloadaur-39af8abf39a51f748bd52f7c386c76717c723e7c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..698a7c21da72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eg-installer
+ pkgdesc = zenityとbashで書かれた項目の追加が簡単なパッケージインストーラー
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://github.com/Hayao0819/EG-Installer
+ arch = any
+ license = MIT
+ depends = zenity
+ depends = bash
+ depends = pacman
+ conflicts = eg-installer-git
+ source = https://github.com/Hayao0819/EG-Installer/archive/v1.10.tar.gz
+ md5sums = SKIP
+
+pkgname = eg-installer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f42b2c719f09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Yamada Hayao <shun819.mail@gmail.com>
+pkgname=eg-installer
+pkgver=1.10
+pkgrel=1
+pkgdesc="zenityとbashで書かれた項目の追加が簡単なパッケージインストーラー"
+arch=('any')
+url=https://github.com/Hayao0819/EG-Installer
+license=('MIT')
+depends=('zenity' 'bash' 'pacman')
+optdepends=()
+source=("https://github.com/Hayao0819/EG-Installer/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+conflicts=('eg-installer-git')
+
+build () {
+cd "EG-Installer-$pkgver"
+mv * ..
+cd ..
+rm -rf EG-Installer-$pkgver/
+rm -f README.md
+rm -f .gitignore
+rm -f LICENSE
+rm -f config
+
+sed -i -e s/'$(cd $(dirname $0) && pwd)\/config'/'\/etc\/eg-installer\/config'/ eg-installer
+
+cat >> config << 'EOF'
+#!/usr/bin/env bash
+
+window_text="EG-Installer v.${version}"
+window_icon="/usr/share/pixmaps/archlinux.png"
+pacman="/etc/eg-installer/pacapt"
+script_dir="/etc/eg-installer/softwares"
+installed_list () { pacman -Q | awk '{print $1}'; }
+EOF
+
+mkdir -p ./usr/bin/
+mv eg-installer ./usr/bin/
+
+mkdir -p ./etc/eg-installer/
+mv config ./etc/eg-installer/
+mv pacapt ./etc/eg-installer/
+mv softwares ./etc/eg-installer/
+
+
+}
+package() {
+ mkdir -p "$pkgdir"
+ rm *.tar.gz
+ cp -r * "$pkgdir"
+}
+