summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:19:35 -0400
committerKyle Keen2015-06-13 00:19:35 -0400
commita5d8289b371b9c931b6169f6df47cdafb0f44f32 (patch)
tree2a02e4fe1065bc7f9f20d3f34310ca53f6818360
downloadaur-a5d8289b371b9c931b6169f6df47cdafb0f44f32.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..55119d1c2717
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = eggwm
+ pkgdesc = A simple and light Qt4 WM. 100% compatible with the EWMH and ICCCM standards.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://code.google.com/p/eggwm/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ source = http://eggwm.googlecode.com/files/eggwm-0.2.tar.gz
+
+pkgname = eggwm
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9be3cbaa441c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eggwm
+ pkgdesc = A simple and light Qt4 WM. 100% compatible with the EWMH and ICCCM standards.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://code.google.com/p/eggwm/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ source = http://eggwm.googlecode.com/files/eggwm-0.2.tar.gz
+ md5sums = 3442e56d9a78a44c349f9e83f15c8eac
+
+pkgname = eggwm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c06a71011bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kyle Keen <keenerd@gmail.com>
+pkgname=eggwm
+pkgver=0.2
+pkgrel=1
+pkgdesc="A simple and light Qt4 WM. 100% compatible with the EWMH and ICCCM standards."
+url="http://code.google.com/p/eggwm/"
+arch=('i686' 'x86_64')
+license=("GPL3")
+depends=('qt4')
+source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('3442e56d9a78a44c349f9e83f15c8eac')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ find installation -type f | xargs chmod -x
+ install -d "$pkgdir/usr/share/eggwm"
+ cp -R installation/* "$pkgdir/usr/share/eggwm"
+ install -D -m755 eggwm "$pkgdir/usr/bin/eggwm"
+}