summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Dye2015-12-25 19:49:55 -0800
committerJosh Dye2015-12-25 19:49:55 -0800
commitc07abec27a10a7eab78747019d75eaa7297f9555 (patch)
tree57c6b2d7edff39ae46570ebae8e8045c2865eb59
downloadaur-c07abec27a10a7eab78747019d75eaa7297f9555.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..294ed03bff8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Dec 26 03:48:56 UTC 2015
+pkgbase = eggwm-qt5
+ pkgdesc = A simple and light Qt5 WM. 100% compatible with the EWMH and ICCCM standards.
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/xiangzhai/eggwm/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-x11extras
+ provides = eggwm
+ conflicts = eggwm
+ source = git+https://github.com/xiangzhai//eggwm.git
+ sha256sums = SKIP
+
+pkgname = eggwm-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c7028d7b4c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: <josh.jpenguin@gmail.com>
+_pkgname=eggwm
+pkgname=$_pkgname-qt5
+pkgver=git
+pkgrel=1
+pkgdesc="A simple and light Qt5 WM. 100% compatible with the EWMH and ICCCM standards."
+url="https://github.com/xiangzhai/eggwm/"
+arch=('i686' 'x86_64')
+license=("GPL3")
+depends=("qt5-base" "qt5-x11extras")
+makedepends=("git" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/xiangzhai//$_pkgname.git")
+sha256sums=("SKIP")
+
+
+build() {
+ cd "$srcdir/$_pkgname"
+ export QT_SELECT=5
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ find installation -type f | xargs chmod -x
+ install -d "$pkgdir/usr/share/eggwm"
+ cp -R installation/* "$pkgdir/usr/share/eggwm"
+ install -D -m755 eggwm "$pkgdir/usr/bin/eggwm"
+}